Skip to content

← Actionable
Medium, CVSS 5.3

mdanter/ecc affected by timing vulnerability in cryptographic side-channels

CVE-2024-33851GHSA-3494-cfwf-56hw

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist mdanter/ecc

    Affected
    <= 1.0.0
    Fixed in
    no fixed version recorded
  • Packagist paragonie/ecc

    Affected
    < 2.0.1
    Fixed in
    2.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-33851: 0.41% estimated exploitation activity in the next 30 days; percentile 35.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

phpecc, as used in all versions of mdanter/ecc, as well as paragonie/ecc before 2.0.1, has a branch-based timing leak in Point addition. (This Composer package is also known as phpecc/phpecc on GitHub, previously known as the Matyas Danter ECC library.) Paragon Initiative Enterprises hard-forked phpecc/phpecc and discovered the issue in the original code, then released v2.0.1 which fixes the vulnerability. The upstream code is no longer maintained and remains vulnerable for all versions.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3494-cfwf-56hw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-33851

Advisory: mdanter/ecc affected by timing vulnerability in cryptographic side-channels
IDs: CVE-2024-33851, GHSA-3494-cfwf-56hw
Record: https://patchnext.com/advisories/cve-2024-33851 (revision 1, source checked 26 Oct 2026, 14:28 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: paragonie/ecc 2.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mdanter/ecc: affected <= 1.0.0
- Packagist paragonie/ecc: affected < 2.0.1; fixed in 2.0.1

## Suggested inspection (read-only)
- Packagist mdanter/ecc: check the installed version with your package manager.
- Packagist paragonie/ecc: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mdanter/ecc, paragonie/ecc.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3494-cfwf-56hw (GitHub-reviewed advisory GHSA-3494-cfwf-56hw lists affected ranges: Packagist paragonie/ecc >=0 =0 <=1.0.0)

Commands are suggestions: review each one before running it.

Loading voting…