Skip to content

← Actionable
High, CVSS 8.2amended

Litestar and Starlite vulnerable to Path Traversal

CVE-2024-32982GHSA-83pv-qr33-2vcf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (litestar 2.8.3, 2.7.2, 2.6.4; starlite 1.51.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI litestar

    Affected
    >= 2.8.0, < 2.8.3>= 2.7.0, < 2.7.2>= 2.0.0, < 2.6.4
    Fixed in
    2.7.2, 2.6.4, 2.8.3
  • PyPI starlite

    Affected
    >= 1.37.0, < 1.51.16
    Fixed in
    1.51.16

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
EPSS
  • CVE-2024-32982: 0.72% estimated exploitation activity in the next 30 days; percentile 54.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Local File Inclusion via Path Traversal in LiteStar Static File Serving A Local File Inclusion (LFI) vulnerability has been discovered in the static file serving component of LiteStar. This vulnerability allows attackers to exploit path traversal flaws, enabling unauthorized access to sensitive files outside the designated directories. Such access can lead to the disclosure of sensitive information or potentially compromise the server. Details The vulnerability is located in the file path handling mechanism within the static content serving function, specifically at line 70 in litestar/staticfiles/base.py. The function fails to properly validate the destination file path derived from user input, thereby permitting directory traversal. The critical code segment is as follows: Given the variables: The function outputs '/Users/brian/sandbox/testvuln/static', incorrectly assuming it is confined to the static directory. This incorrect validation facilitates directory traversal,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-83pv-qr33-2vcf

  2. Revision 1 · created ·

    Published from osv record GHSA-83pv-qr33-2vcf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-32982

Advisory: Litestar and Starlite vulnerable to Path Traversal
IDs: CVE-2024-32982, GHSA-83pv-qr33-2vcf
Record: https://patchnext.com/advisories/cve-2024-32982 (revision 2, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: litestar 2.8.3, 2.7.2, 2.6.4; starlite 1.51.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI litestar: affected >= 2.8.0, < 2.8.3; >= 2.7.0, < 2.7.2; >= 2.0.0, < 2.6.4; fixed in 2.7.2, 2.6.4, 2.8.3
- PyPI starlite: affected >= 1.37.0, < 1.51.16; fixed in 1.51.16

## Suggested inspection (read-only)
- `python -m pip show litestar`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show starlite`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on litestar, starlite.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-83pv-qr33-2vcf (OSV record GHSA-83pv-qr33-2vcf lists affected ranges: PyPI litestar >=2.8.0 =2.7.0 =2.0.0 =1.37.0 <1.51.16 (fixed))
- Verified: https://github.com/advisories/GHSA-83pv-qr33-2vcf (GitHub-reviewed advisory GHSA-83pv-qr33-2vcf lists affected ranges: PyPI litestar >=2.8.0 =2.7.0 =2.0.0 =1.37.0 <1.51.16)

Commands are suggestions: review each one before running it.

Loading voting…