Skip to content

← Actionable
Critical, CVSS 9.0

Apollo Router vulnerable to Critical Regression In Query Plan Cache

CVE-2024-32971GHSA-q9p4-hw9m-fj2v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apollo-router 1.45.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2024-32971: 0.73% estimated exploitation activity in the next 30 days; percentile 54.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Any instance of Apollo Router 1.44.0 or 1.45.0 that is using Distributed Query Plan Caching is impacted. These versions were released on 2024-04-12 and 2024-04-22 respectively. The affected versions of Apollo Router contain a bug that could lead to unexpected operations being executed, which can result in unintended data or effects. This only affects Router instances configured to use distributed query plan caching. Router versions other than the ones listed above, and all Router deployments that are not using distributed query plan caching, are unaffected by this defect. If you are using the affected versions, you can check your router’s configuration YAML to verify if you are impacted: A full reference on the Distributed Query Plan Caching feature is available here. Impact detail The root cause of this defect is a bug in Apollo Router’s cache retrieval logic: When this defect is present and distributed query planning caching is enabled, asking the Router to execute an…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q9p4-hw9m-fj2v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-32971

Advisory: Apollo Router vulnerable to Critical Regression In Query Plan Cache
IDs: CVE-2024-32971, GHSA-q9p4-hw9m-fj2v
Record: https://patchnext.com/advisories/cve-2024-32971 (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apollo-router 1.45.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io apollo-router: affected >= 1.44.0, < 1.45.1; fixed in 1.45.1

## Suggested inspection (read-only)
- crates.io apollo-router: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apollo-router.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q9p4-hw9m-fj2v (GitHub-reviewed advisory GHSA-q9p4-hw9m-fj2v lists affected ranges: crates.io apollo-router >=1.44.0 <1.45.1)

Commands are suggestions: review each one before running it.

Loading voting…