Phlex vulnerable to Cross-site Scripting (XSS) via maliciously formed HTML attribute names and values
CVE-2024-32970GHSA-9p57-h987-4vgx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phlex 1.10.2, 1.9.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems phlex
- Affected
- < 1.9.3>= 1.10.0, < 1.10.2
- Fixed in
- 1.9.3, 1.10.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9p57-h987-4vgx lists affected ranges: RubyGems phlex >=0 =1.10.0 <1.10.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
- EPSS
- CVE-2024-32970: 0.71% estimated exploitation activity in the next 30 days; percentile 53.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
There is a potential cross-site scripting (XSS) vulnerability that can be exploited via maliciously crafted user data. The reason these issues were not detected before is the escapes were working as designed. However, their design didn't take into account just how recklessly permissive browser are when it comes to executing unsafe JavaScript via HTML attributes. Impact If you render an <a tag with an href attribute set to a user-provided link, that link could potentially execute JavaScript when clicked by another user. If you splat user-provided attributes when rendering any HTML or SVG tag, malicious event attributes could be included in the output, executing JavaScript when the events are triggered by another user. Patches Patches are available on RubyGems for all minor versions released in the last year. - 1.10.2 - 1.9.3 If you are on main, it has been patched since da8f943 Workarounds Configuring a Content Security Policy that does not allow unsafe-inline would effectively…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9p57-h987-4vgx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-32970 Advisory: Phlex vulnerable to Cross-site Scripting (XSS) via maliciously formed HTML attribute names and values IDs: CVE-2024-32970, GHSA-9p57-h987-4vgx Record: https://patchnext.com/advisories/cve-2024-32970 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phlex 1.10.2, 1.9.3. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems phlex: affected < 1.9.3; >= 1.10.0, < 1.10.2; fixed in 1.9.3, 1.10.2 ## Suggested inspection (read-only) - RubyGems phlex: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phlex. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9p57-h987-4vgx (GitHub-reviewed advisory GHSA-9p57-h987-4vgx lists affected ranges: RubyGems phlex >=0 =1.10.0 <1.10.2) Commands are suggestions: review each one before running it.
Loading voting…