vantage6 collaboration admins can extend their influence by expanding the collaboration
CVE-2024-32969GHSA-99r4-cjp4-3hmx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vantage6 4.5.0rc3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vantage6
- Affected
- < 4.5.0rc3
- Fixed in
- 4.5.0rc3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-99r4-cjp4-3hmx lists affected ranges: PyPI vantage6 >=0 <4.5.0rc3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-99r4-cjp4-3hmx lists affected ranges: PyPI vantage6 >=0 <4.5.0rc3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2024-32969: 0.32% estimated exploitation activity in the next 30 days; percentile 24.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Collaboration administrators can add extra organizations to their collaboration. When doing that, they extend their influence: for instance, for organizations that they include, they can then create new users for which they know the passwords, and use that to read task results of other collaborations that that organization is involved in. Only relatively trusted users - with access to manage a collaboration - are able to do this, which reduces the impact. Patches No Workarounds No
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-99r4-cjp4-3hmx
- Revision 1 · created ·
Published from osv record GHSA-99r4-cjp4-3hmx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-32969 Advisory: vantage6 collaboration admins can extend their influence by expanding the collaboration IDs: CVE-2024-32969, GHSA-99r4-cjp4-3hmx Record: https://patchnext.com/advisories/cve-2024-32969 (revision 2, source checked 26 Oct 2026, 13:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vantage6 4.5.0rc3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vantage6: affected < 4.5.0rc3; fixed in 4.5.0rc3 ## Suggested inspection (read-only) - `python -m pip show vantage6`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vantage6. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-99r4-cjp4-3hmx (OSV record GHSA-99r4-cjp4-3hmx lists affected ranges: PyPI vantage6 >=0 <4.5.0rc3 (fixed)) - Verified: https://github.com/advisories/GHSA-99r4-cjp4-3hmx (GitHub-reviewed advisory GHSA-99r4-cjp4-3hmx lists affected ranges: PyPI vantage6 >=0 <4.5.0rc3) Commands are suggestions: review each one before running it.
Loading voting…