static-web-server vulnerable to stored Cross-site Scripting in directory listings via file names
CVE-2024-32966GHSA-rwfq-v4hq-h7fg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (static-web-server 2.30.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io static-web-server
- Affected
- < 2.30.0
- Fixed in
- 2.30.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rwfq-v4hq-h7fg lists affected ranges: crates.io static-web-server >=0 <2.30.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:L
- EPSS
- CVE-2024-32966: 0.37% estimated exploitation activity in the next 30 days; percentile 30.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary If directory listings are enabled for a directory that an untrusted user has upload privileges for, a malicious file name like <img src=x onerror=alert(1).txt will allow JavaScript code execution in the context of the web server’s domain. Details SWS generally does not perform escaping of HTML entities on any values inserted in the directory listing. At the very least filename and currentpath could contain malicious data however. fileuri could also be malicious but the relevant scenarios seem to be all caught by hyper. Impact For any web server that allow users to upload files or create directories under a name of their choosing this becomes a stored XSS vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rwfq-v4hq-h7fg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-32966 Advisory: static-web-server vulnerable to stored Cross-site Scripting in directory listings via file names IDs: CVE-2024-32966, GHSA-rwfq-v4hq-h7fg Record: https://patchnext.com/advisories/cve-2024-32966 (revision 1, source checked 26 Oct 2026, 15:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: static-web-server 2.30.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io static-web-server: affected < 2.30.0; fixed in 2.30.0 ## Suggested inspection (read-only) - crates.io static-web-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on static-web-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rwfq-v4hq-h7fg (GitHub-reviewed advisory GHSA-rwfq-v4hq-h7fg lists affected ranges: crates.io static-web-server >=0 <2.30.0) Commands are suggestions: review each one before running it.
Loading voting…