Skip to content

← Actionable
Medium, CVSS 4.2

Navidrome Parameter Tampering vulnerability

CVE-2024-32963GHSA-4jrx-5w4h-3gpm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/navidrome/navidrome 0.52.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.2 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2024-32963: 0.41% estimated exploitation activity in the next 30 days; percentile 35.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Parameter tampering is a vulnerability where an attacker has the ability to manipulate parameter values in the HTTP requests. Details The attacker is able to change the parameter values in the body and successfully impersonate another user. In this case, the attacker created a playlist, added song, posted arbitrary comment, set the playlist to be public, and put the admin as the owner of the playlist. Impact Each known user is impacted. An attacker can obtain the ownerId from shared playlist information, meaning every user who has shared a playlist is also impacted, as they can be impersonated.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4jrx-5w4h-3gpm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-32963

Advisory: Navidrome Parameter Tampering vulnerability
IDs: CVE-2024-32963, GHSA-4jrx-5w4h-3gpm
Record: https://patchnext.com/advisories/cve-2024-32963 (revision 1, source checked 26 Oct 2026, 15:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/navidrome/navidrome 0.52.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/navidrome/navidrome: affected < 0.52.0; fixed in 0.52.0

## Suggested inspection (read-only)
- Go github.com/navidrome/navidrome: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/navidrome/navidrome.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4jrx-5w4h-3gpm (GitHub-reviewed advisory GHSA-4jrx-5w4h-3gpm lists affected ranges: Go github.com/navidrome/navidrome >=0 <0.52.0)

Commands are suggestions: review each one before running it.

Loading voting…