Wagtail has permission check bypass when editing a model with per-field restrictions through wagtail.contrib.settings or ModelViewSet
CVE-2024-32882GHSA-w2v8-php4-p8hc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wagtail 6.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI wagtail
- Affected
- >= 6.0.0, < 6.0.3
- Fixed in
- 6.0.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w2v8-php4-p8hc lists affected ranges: PyPI wagtail >=6.0.0 <6.0.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w2v8-php4-p8hc lists affected ranges: PyPI wagtail >=6.0.0 <6.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2024-32882: 0.48% estimated exploitation activity in the next 30 days; percentile 41.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact If a model has been made available for editing through the wagtail.contrib.settings module or ModelViewSet, and the permission argument on FieldPanel has been used to further restrict access to one or more fields of the model, a user with edit permission over the model but not the specific field can craft an HTTP POST request that bypasses the permission check on the individual field, allowing them to update its value. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin, or by a user who has not been granted edit access to the model in question. The editing interfaces for pages and snippets are also unaffected. Patches Patched versions have been released as Wagtail 6.0.3 and 6.1. Wagtail releases prior to 6.0 are unaffected. Workarounds Site owners who are unable to upgrade to a patched version can avoid the vulnerability in ModelViewSet by registering the model as a snippet instead. No workaround is available for…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-w2v8-php4-p8hc
- Revision 1 · created ·
Published from osv record GHSA-w2v8-php4-p8hc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-32882 Advisory: Wagtail has permission check bypass when editing a model with per-field restrictions through `wagtail.contrib.settings` or `ModelViewSet` IDs: CVE-2024-32882, GHSA-w2v8-php4-p8hc Record: https://patchnext.com/advisories/cve-2024-32882 (revision 2, source checked 26 Oct 2026, 13:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wagtail 6.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI wagtail: affected >= 6.0.0, < 6.0.3; fixed in 6.0.3 ## Suggested inspection (read-only) - `python -m pip show wagtail`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wagtail. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w2v8-php4-p8hc (OSV record GHSA-w2v8-php4-p8hc lists affected ranges: PyPI wagtail >=6.0.0 <6.0.3 (fixed)) - Verified: https://github.com/advisories/GHSA-w2v8-php4-p8hc (GitHub-reviewed advisory GHSA-w2v8-php4-p8hc lists affected ranges: PyPI wagtail >=6.0.0 <6.0.3) Commands are suggestions: review each one before running it.
Loading voting…