social-auth-app-django affected by Improper Handling of Case Sensitivity
CVE-2024-32879GHSA-2gr8-3wc7-xhj3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (social-auth-app-django 5.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 5.4.1
- Fixed in
- 5.4.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2gr8-3wc7-xhj3 lists affected ranges: PyPI social-auth-app-django >=0 <5.4.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2gr8-3wc7-xhj3 lists affected ranges: PyPI social-auth-app-django >=0 <5.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.9 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N
- EPSS
- CVE-2024-32879: 0.58% estimated exploitation activity in the next 30 days; percentile 47.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Due to default case-insensitive collation in MySQL or MariaDB databases, third-party authentication user IDs are not case-sensitive and could cause different IDs to match. Patches This issue has been addressed by https://github.com/python-social-auth/social-app-django/pull/566 and fix released in 5.4.1. Workarounds An immediate workaround would be to change collation of the affected field: References This issue was discovered by folks at https://opencraft.com/.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-2gr8-3wc7-xhj3
- Revision 1 · created ·
Published from osv record GHSA-2gr8-3wc7-xhj3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-32879 Advisory: social-auth-app-django affected by Improper Handling of Case Sensitivity IDs: CVE-2024-32879, GHSA-2gr8-3wc7-xhj3 Record: https://patchnext.com/advisories/cve-2024-32879 (revision 2, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: social-auth-app-django 5.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI social-auth-app-django: affected < 5.4.1; fixed in 5.4.1 ## Suggested inspection (read-only) - `python -m pip show social-auth-app-django`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on social-auth-app-django. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2gr8-3wc7-xhj3 (OSV record GHSA-2gr8-3wc7-xhj3 lists affected ranges: PyPI social-auth-app-django >=0 <5.4.1 (fixed)) - Verified: https://github.com/advisories/GHSA-2gr8-3wc7-xhj3 (GitHub-reviewed advisory GHSA-2gr8-3wc7-xhj3 lists affected ranges: PyPI social-auth-app-django >=0 <5.4.1) Commands are suggestions: review each one before running it.
Loading voting…