Reflected Cross-site Scripting in yiisoft/yii2 Debug mode
CVE-2024-32877GHSA-qg5r-95m4-mjgj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (yiisoft/yii2 2.0.49.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist yiisoft/yii2
- Affected
- >= 2.0.43, < 2.0.49.4
- Fixed in
- 2.0.49.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qg5r-95m4-mjgj lists affected ranges: Packagist yiisoft/yii2 >=2.0.43 <2.0.49.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.2 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N
- EPSS
- CVE-2024-32877: 0.35% estimated exploitation activity in the next 30 days; percentile 28.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
During the internal penetration testing of our product based on Yii2, we discovered an XSS vulnerability within the framework itself. This issue is relevant for the latest version of Yii2 (2.0.49.3). Conditions for vulnerability reproduction The framework is in debug mode (YIIDEBUG set to true). The php.ini setting zend.exceptionignoreargs is set to Off (default value). An attacker induces an exception in the application, leading to a stack trace page being displayed. Vulnerability description The issue lies in the mechanism for displaying function argument values in the stack trace. The vulnerability manifests when an argument's value exceeds 32 characters. For convenience, argument values exceeding this limit are truncated and displayed with an added "...". The full argument value becomes visible when hovering over it with the mouse, as it is displayed in the title attribute of a span tag. However, the use of a double quote (") allows an attacker to break out of the title…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qg5r-95m4-mjgj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-32877 Advisory: Reflected Cross-site Scripting in yiisoft/yii2 Debug mode IDs: CVE-2024-32877, GHSA-qg5r-95m4-mjgj Record: https://patchnext.com/advisories/cve-2024-32877 (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: yiisoft/yii2 2.0.49.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist yiisoft/yii2: affected >= 2.0.43, < 2.0.49.4; fixed in 2.0.49.4 ## Suggested inspection (read-only) - Packagist yiisoft/yii2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on yiisoft/yii2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qg5r-95m4-mjgj (GitHub-reviewed advisory GHSA-qg5r-95m4-mjgj lists affected ranges: Packagist yiisoft/yii2 >=2.0.43 <2.0.49.4) Commands are suggestions: review each one before running it.
Loading voting…