Skip to content

← Actionable
Critical, CVSS 9.3amended

Malicious Long Unicode filenames may cause a Multiple Application-level Denial of Service

CVE-2024-32874GHSA-w4h6-9wrp-v5jq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (frigate 0.13.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI frigate

    Affected
    < 0.13.2
    Fixed in
    0.13.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:H
EPSS
  • CVE-2024-32874: 0.77% estimated exploitation activity in the next 30 days; percentile 55.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Important: Exploiting this vulnerability requires the attacker to have access to your Frigate instance, which means they could also just delete all of your recordings or perform any other action. If you have configured authentication in front of Frigate via a reverse proxy, then this vulnerability is not exploitable without first getting around your authentication method. For many obvious reasons in addition to this one, please don't expose your Frigate instance publicly without any kind of authentication.

Summary When uploading a file or retrieving the filename, a user may intentionally use a large Unicode filename which would lead to a application-level denial of service. This is due to no limitation set on the length of the filename and the costy use of the Unicode normalization with the form NFKD under the hood of `secure_filename()`. I idenfied multiple vulnerable paths on blakeblackshear/frigate repository. In all of…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from osv record GHSA-w4h6-9wrp-v5jq

  2. Revision 3 · amended ·

    Amended from ghsa record GHSA-w4h6-9wrp-v5jq

  3. Revision 2 · amended ·

    Amended from ghsa record GHSA-w4h6-9wrp-v5jq

  4. Revision 1 · created ·

    Published from osv record GHSA-w4h6-9wrp-v5jq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-32874

Advisory: Malicious Long Unicode filenames may cause a Multiple Application-level Denial of Service
IDs: CVE-2024-32874, GHSA-w4h6-9wrp-v5jq
Record: https://patchnext.com/advisories/cve-2024-32874 (revision 4, source checked 28 Oct 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: frigate 0.13.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI frigate: affected < 0.13.2; fixed in 0.13.2

## Suggested inspection (read-only)
- `python -m pip show frigate`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on frigate.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w4h6-9wrp-v5jq (OSV record GHSA-w4h6-9wrp-v5jq lists affected ranges: PyPI frigate >=0 <0.13.2 (fixed))
- Verified: https://github.com/advisories/GHSA-w4h6-9wrp-v5jq (GitHub-reviewed advisory GHSA-w4h6-9wrp-v5jq lists affected ranges: PyPI frigate >=0 <0.13.2)

Commands are suggestions: review each one before running it.

Loading voting…