Skip to content

← Actionable
Critical, CVSS 9.8amended

llama-index-core Command Injection vulnerability

CVE-2024-3271GHSA-r6gp-rff2-p3hf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (llama-index-core 0.10.24), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-3271: 2.89% estimated exploitation activity in the next 30 days; percentile 86.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A command injection vulnerability exists in the run-llama/llamaindex repository, specifically within the safeeval function. Attackers can bypass the intended security mechanism, which checks for the presence of underscores in code generated by LLM, to execute arbitrary code. This is achieved by crafting input that does not contain an underscore but still results in the execution of OS commands. The vulnerability allows for remote code execution (RCE) on the server hosting the application.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-r6gp-rff2-p3hf

  2. Revision 1 · created ·

    Published from osv record GHSA-r6gp-rff2-p3hf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-3271

Advisory: llama-index-core Command Injection vulnerability
IDs: CVE-2024-3271, GHSA-r6gp-rff2-p3hf
Record: https://patchnext.com/advisories/cve-2024-3271 (revision 2, source checked 26 Oct 2026, 13:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: llama-index-core 0.10.24. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI llama-index-core: affected < 0.10.24; fixed in 0.10.24

## Suggested inspection (read-only)
- `python -m pip show llama-index-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on llama-index-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r6gp-rff2-p3hf (OSV record GHSA-r6gp-rff2-p3hf lists affected ranges: PyPI llama-index-core >=0 <0.10.24 (fixed))
- Verified: https://github.com/advisories/GHSA-r6gp-rff2-p3hf (GitHub-reviewed advisory GHSA-r6gp-rff2-p3hf lists affected ranges: PyPI llama-index-core >=0 <0.10.24)

Commands are suggestions: review each one before running it.

Loading voting…