Skip to content

← Actionable
High, CVSS 8.1

Npgsql vulnerable to SQL Injection via Protocol Message Size Overflow

CVE-2024-32655GHSA-x9vc-6hfv-hg8c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (npgsql 8.0.3, 7.0.7, 6.0.11, 5.0.18, 4.1.13, 4.0.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • NuGet npgsql

    Affected
    >= 8.0.0, < 8.0.3<= 4.0.13>= 4.1.0, < 4.1.13>= 5.0.0, < 5.0.18>= 6.0.0, < 6.0.11>= 7.0.0, < 7.0.7
    Fixed in
    4.0.14, 8.0.3, 6.0.11, 7.0.7, 5.0.18, 4.1.13

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-32655: 1.72% estimated exploitation activity in the next 30 days; percentile 77.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The WriteBind() method in src/Npgsql/Internal/NpgsqlConnector.FrontendMessages.cs uses int variables to store the message length and the sum of parameter lengths. Both variables overflow when the sum of parameter lengths becomes too large. This causes Npgsql to write a message size that is too small when constructing a Postgres protocol message to send it over the network to the database. When parsing the message, the database will only read a small number of bytes and treat any following bytes as new messages while they belong to the old message. Attackers can abuse this to inject arbitrary Postgres protocol messages into the connection, leading to the execution of arbitrary SQL statements on the application's behalf. Impact Attackers can issue arbitrary SQL statements to the database on behalf of the application. The final impact depends on the application that uses Npgsql, the data it stores in Postgres, etc.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x9vc-6hfv-hg8c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-32655

Advisory: Npgsql vulnerable to SQL Injection via Protocol Message Size Overflow
IDs: CVE-2024-32655, GHSA-x9vc-6hfv-hg8c
Record: https://patchnext.com/advisories/cve-2024-32655 (revision 1, source checked 26 Oct 2026, 17:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: npgsql 8.0.3, 7.0.7, 6.0.11, 5.0.18, 4.1.13, 4.0.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet npgsql: affected >= 8.0.0, < 8.0.3; <= 4.0.13; >= 4.1.0, < 4.1.13; >= 5.0.0, < 5.0.18; >= 6.0.0, < 6.0.11; >= 7.0.0, < 7.0.7; fixed in 4.0.14, 8.0.3, 6.0.11, 7.0.7, 5.0.18, 4.1.13

## Suggested inspection (read-only)
- NuGet npgsql: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on npgsql.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x9vc-6hfv-hg8c (GitHub-reviewed advisory GHSA-x9vc-6hfv-hg8c lists affected ranges: NuGet npgsql >=8.0.0 =0 =4.1.0 =5.0.0 =6.0.0 =7.0.0 <7.0.7)

Commands are suggestions: review each one before running it.

Loading voting…