Skip to content

← Actionable
High, CVSS 7.5amended

@hono/node-server has Denial of Service risk when receiving Host header that cannot be parsed

CVE-2024-32652GHSA-hgxw-5xg3-69jx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@hono/node-server 1.10.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2024-32652: 0.88% estimated exploitation activity in the next 30 days; percentile 59.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The application hangs when receiving a Host header with a value that @hono/node-server can't handle well. Invalid values are those that cannot be parsed by the URL as a hostname such as an empty string, slashes /, and other strings. For example, if you have a simple application: Sending a request with a Host header with an empty value to it: The results: Patches The version 1.10.1 includes the fix for this issue. But, you should use 1.11.0, which has other fixes related to this issue. https://github.com/honojs/node-server/issues/160 https://github.com/honojs/node-server/issues/161 Workarounds Nothing. Upgrade your @hono/node-server. References https://github.com/honojs/node-server/issues/159

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hgxw-5xg3-69jx

  2. Revision 1 · created ·

    Published from osv record GHSA-hgxw-5xg3-69jx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-32652

Advisory: @hono/node-server has Denial of Service risk when receiving Host header that cannot be parsed
IDs: CVE-2024-32652, GHSA-hgxw-5xg3-69jx
Record: https://patchnext.com/advisories/cve-2024-32652 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @hono/node-server 1.10.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @hono/node-server: affected >= 1.3.0, < 1.10.1; fixed in 1.10.1

## Suggested inspection (read-only)
- `npm ls @hono/node-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @hono/node-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hgxw-5xg3-69jx (OSV record GHSA-hgxw-5xg3-69jx lists affected ranges: npm @hono/node-server >=1.3.0 <1.10.1 (fixed))
- Verified: https://github.com/advisories/GHSA-hgxw-5xg3-69jx (GitHub-reviewed advisory GHSA-hgxw-5xg3-69jx lists affected ranges: npm @hono/node-server >=1.3.0 <1.10.1)

Commands are suggestions: review each one before running it.

Loading voting…