Skip to content

← Actionable
Medium, CVSS 5.3amended

vyper performs multiple eval of sqrt() argument built in

CVE-2024-32649GHSA-5jrj-52x8-m64h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vyper 0.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vyper

    Affected
    < 0.4.0
    Fixed in
    0.4.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2024-32649: 0.46% estimated exploitation activity in the next 30 days; percentile 39.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Using the sqrt builtin can result in multiple eval evaluation of side effects when the argument has side-effects. The bug is more difficult (but not impossible!) to trigger as of 0.3.4, when the unique symbol fence was introduced (https://github.com/vyperlang/vyper/pull/2914). A contract search was performed and no vulnerable contracts were found in production. Details It can be seen that the buildIR function of the sqrt builtin doesn't cache the argument to the stack: https://github.com/vyperlang/vyper/blob/4595938734d9988f8e46e8df38049ae0559abedb/vyper/builtins/functions.py#L2151 As such, it can be evaluated multiple times (instead of retrieving the value from the stack). PoC With at least Vyper version 0.2.15+commit.6e7dba7 the following contract: passes the following test: Patches Patched in https://github.com/vyperlang/vyper/pull/3976. Impact No vulnerable production contracts were found.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5jrj-52x8-m64h

  2. Revision 1 · created ·

    Published from osv record GHSA-5jrj-52x8-m64h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-32649

Advisory: vyper performs multiple eval of `sqrt()` argument built in
IDs: CVE-2024-32649, GHSA-5jrj-52x8-m64h
Record: https://patchnext.com/advisories/cve-2024-32649 (revision 2, source checked 26 Oct 2026, 13:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vyper 0.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vyper: affected < 0.4.0; fixed in 0.4.0

## Suggested inspection (read-only)
- `python -m pip show vyper`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vyper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5jrj-52x8-m64h (OSV record GHSA-5jrj-52x8-m64h lists affected ranges: PyPI vyper >=0 <0.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-5jrj-52x8-m64h (GitHub-reviewed advisory GHSA-5jrj-52x8-m64h lists affected ranges: PyPI vyper >=0 <0.4.0)

Commands are suggestions: review each one before running it.

Loading voting…