vyper default functions don't respect nonreentrancy keys
CVE-2024-32648GHSA-m2v9-w374-5hj9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vyper 0.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vyper
- Affected
- <= 0.2.16
- Fixed in
- 0.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m2v9-w374-5hj9 lists affected ranges: PyPI vyper >=0 <0.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m2v9-w374-5hj9 lists affected ranges: PyPI vyper >=0 <=0.2.16
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2024-32648: 0.41% estimated exploitation activity in the next 30 days; percentile 35.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Prior to v0.3.0, default() functions did not respect the @nonreentrancy decorator and the lock was not emitted. This is a known bug and was already visible in the issue tracker (https://github.com/vyperlang/vyper/issues/2455), but it is being re-issued as an advisory so that tools relying on the advisory publication list can incorporate it into their searches. A contract search was additionally performed and no vulnerable contracts were found in production. PoC after codegen: Impact No vulnerable production contracts were found. Additionally, using a lock on a default function is a very sparsely used pattern. As such, the impact is low.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-m2v9-w374-5hj9
- Revision 1 · created ·
Published from osv record GHSA-m2v9-w374-5hj9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-32648 Advisory: vyper default functions don't respect nonreentrancy keys IDs: CVE-2024-32648, GHSA-m2v9-w374-5hj9 Record: https://patchnext.com/advisories/cve-2024-32648 (revision 2, source checked 26 Oct 2026, 13:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vyper 0.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vyper: affected <= 0.2.16; fixed in 0.3.0 ## Suggested inspection (read-only) - `python -m pip show vyper`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vyper. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m2v9-w374-5hj9 (OSV record GHSA-m2v9-w374-5hj9 lists affected ranges: PyPI vyper >=0 <0.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-m2v9-w374-5hj9 (GitHub-reviewed advisory GHSA-m2v9-w374-5hj9 lists affected ranges: PyPI vyper >=0 <=0.2.16) Commands are suggestions: review each one before running it.
Loading voting…