vyper performs double eval of the slice start/length args in certain cases
CVE-2024-32646GHSA-r56x-j438-vw5m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vyper 0.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vyper
- Affected
- < 0.4.0
- Fixed in
- 0.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r56x-j438-vw5m lists affected ranges: PyPI vyper >=0 <0.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r56x-j438-vw5m lists affected ranges: PyPI vyper >=0 <0.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2024-32646: 0.46% estimated exploitation activity in the next 30 days; percentile 39.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Using the slice builtin can result in a double eval vulnerability when the buffer argument is either msg.data, self.code or <address.code and either the start or length arguments have side-effects. A contract search was performed and no vulnerable contracts were found in production. Having side-effects in the start and length patterns is also an unusual pattern which is not that likely to show up in user code. It is also much harder (but not impossible!) to trigger the bug since 0.3.4 since the unique symbol fence was introduced (https://github.com/vyperlang/vyper/pull/2914). Details It can be seen that the buildadhocslicenode function of the slice builtin doesn't cache the mentioned arguments to the stack: https://github.com/vyperlang/vyper/blob/4595938734d9988f8e46e8df38049ae0559abedb/vyper/builtins/functions.py#L244 As such, they can be evaluated multiple times (instead of retrieving the value from the stack). PoC with Vyper version 0.3.3+commit.48e326f the call to foo…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-r56x-j438-vw5m
- Revision 1 · created ·
Published from osv record GHSA-r56x-j438-vw5m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-32646 Advisory: vyper performs double eval of the slice start/length args in certain cases IDs: CVE-2024-32646, GHSA-r56x-j438-vw5m Record: https://patchnext.com/advisories/cve-2024-32646 (revision 2, source checked 26 Oct 2026, 13:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vyper 0.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vyper: affected < 0.4.0; fixed in 0.4.0 ## Suggested inspection (read-only) - `python -m pip show vyper`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vyper. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r56x-j438-vw5m (OSV record GHSA-r56x-j438-vw5m lists affected ranges: PyPI vyper >=0 <0.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-r56x-j438-vw5m (GitHub-reviewed advisory GHSA-r56x-j438-vw5m lists affected ranges: PyPI vyper >=0 <0.4.0) Commands are suggestions: review each one before running it.
Loading voting…