vyper performs incorrect topic logging in raw_log
CVE-2024-32645GHSA-xchq-w5r3-4wg3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vyper 0.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vyper
- Affected
- < 0.4.0
- Fixed in
- 0.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xchq-w5r3-4wg3 lists affected ranges: PyPI vyper >=0 <0.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xchq-w5r3-4wg3 lists affected ranges: PyPI vyper >=0 <0.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2024-32645: 0.46% estimated exploitation activity in the next 30 days; percentile 39.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Incorrect values can be logged when rawlog builtin is called with memory or storage arguments to be used as topics. A contract search was performed and no vulnerable contracts were found in production. In particular, no uses of rawlog() were found at all in production; it is apparently not a well-known function. Details The buildIR function of the RawLog class fails to properly unwrap the variables provided as topics. Consequently, incorrect values are logged as topics. PoC Patches Fixed in https://github.com/vyperlang/vyper/pull/3977. Impact Incorrect values can be logged which may result in unexpected behavior in client-side applications relying on these logs.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xchq-w5r3-4wg3
- Revision 1 · created ·
Published from osv record GHSA-xchq-w5r3-4wg3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-32645 Advisory: vyper performs incorrect topic logging in raw_log IDs: CVE-2024-32645, GHSA-xchq-w5r3-4wg3 Record: https://patchnext.com/advisories/cve-2024-32645 (revision 2, source checked 26 Oct 2026, 13:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vyper 0.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vyper: affected < 0.4.0; fixed in 0.4.0 ## Suggested inspection (read-only) - `python -m pip show vyper`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vyper. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xchq-w5r3-4wg3 (OSV record GHSA-xchq-w5r3-4wg3 lists affected ranges: PyPI vyper >=0 <0.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-xchq-w5r3-4wg3 (GitHub-reviewed advisory GHSA-xchq-w5r3-4wg3 lists affected ranges: PyPI vyper >=0 <0.4.0) Commands are suggestions: review each one before running it.
Loading voting…