Sentry vulnerable to leaking superuser cleartext password in logs
CVE-2024-32474GHSA-6cjm-4pxw-7xp9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sentry 24.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI sentry
- Affected
- >= 24.3.0, < 24.4.1
- Fixed in
- 24.4.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6cjm-4pxw-7xp9 lists affected ranges: PyPI sentry >=24.3.0 <24.4.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6cjm-4pxw-7xp9 lists affected ranges: PyPI sentry >=24.3.0 <24.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2024-32474: 0.43% estimated exploitation activity in the next 30 days; percentile 37.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When authenticating as a superuser to a self-hosted Sentry instance with a username and password, the password is leaked as cleartext in logs under the event: auth-index.validatesuperuser. An attacker with access to the log data could use these leaked credentials to login to the Sentry system as superuser. Patches - Self-hosted users on affected versions should upgrade to 24.4.1 or later. - Sentry SaaS users do not need to take any action. This vulnerability is not applicable to SaaS. Workarounds Users can configure the logging level to exclude logs of the INFO level and only generate logs for levels at WARNING or higher. For details on configuring self-hosted Sentry's logging level see our documentation at: https://develop.sentry.dev/config/#logging References - Bug introduced in https://github.com/getsentry/sentry/pull/66393 - Security fix in https://github.com/getsentry/sentry/pull/69148
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-6cjm-4pxw-7xp9
- Revision 1 · created ·
Published from osv record GHSA-6cjm-4pxw-7xp9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-32474 Advisory: Sentry vulnerable to leaking superuser cleartext password in logs IDs: CVE-2024-32474, GHSA-6cjm-4pxw-7xp9 Record: https://patchnext.com/advisories/cve-2024-32474 (revision 2, source checked 26 Oct 2026, 13:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sentry 24.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI sentry: affected >= 24.3.0, < 24.4.1; fixed in 24.4.1 ## Suggested inspection (read-only) - `python -m pip show sentry`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sentry. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6cjm-4pxw-7xp9 (OSV record GHSA-6cjm-4pxw-7xp9 lists affected ranges: PyPI sentry >=24.3.0 <24.4.1 (fixed)) - Verified: https://github.com/advisories/GHSA-6cjm-4pxw-7xp9 (GitHub-reviewed advisory GHSA-6cjm-4pxw-7xp9 lists affected ranges: PyPI sentry >=24.3.0 <24.4.1) Commands are suggestions: review each one before running it.
Loading voting…