Skip to content

← Actionable
Medium, CVSS 6.0

Decidim::Admin vulnerable to cross-site scripting (XSS) in the admin activity log

CVE-2024-32034GHSA-rx9f-5ggv-5rh6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (decidim-admin 0.28.2, 0.27.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems decidim-admin

    Affected
    <= 0.27.6>= 0.28.0, <= 0.28.1
    Fixed in
    0.28.2, 0.27.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.0 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2024-32034: 0.37% estimated exploitation activity in the next 30 days; percentile 31.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The admin panel is subject to potential XSS attach in case an admin assigns a valuator to a proposal, or does any other action that generates an admin activity log where one of the resources has an XSS crafted. Patches N/A Workarounds Redirect the pages /admin and /admin/logs to other admin pages to prevent this access (i.e. /admin/organization/edit) References OWASP ASVS v4.0.3-5.1.3

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rx9f-5ggv-5rh6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-32034

Advisory: Decidim::Admin vulnerable to cross-site scripting (XSS) in the admin activity log
IDs: CVE-2024-32034, GHSA-rx9f-5ggv-5rh6
Record: https://patchnext.com/advisories/cve-2024-32034 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: decidim-admin 0.28.2, 0.27.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems decidim-admin: affected <= 0.27.6; >= 0.28.0, <= 0.28.1; fixed in 0.28.2, 0.27.7

## Suggested inspection (read-only)
- RubyGems decidim-admin: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on decidim-admin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rx9f-5ggv-5rh6 (GitHub-reviewed advisory GHSA-rx9f-5ggv-5rh6 lists affected ranges: RubyGems decidim-admin >=0 =0.28.0 <=0.28.1)

Commands are suggestions: review each one before running it.

Loading voting…