NiceGUI allows potential access to local file system
CVE-2024-32005GHSA-mwc7-64wg-pgvj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nicegui 1.4.21), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI nicegui
- Affected
- >= 1.4.6, < 1.4.21
- Fixed in
- 1.4.21
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mwc7-64wg-pgvj lists affected ranges: PyPI nicegui >=1.4.6 <1.4.21 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mwc7-64wg-pgvj lists affected ranges: PyPI nicegui >=1.4.6 <1.4.21
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L
- EPSS
- CVE-2024-32005: 0.76% estimated exploitation activity in the next 30 days; percentile 55.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
NiceGUI is an easy-to-use, Python-based UI framework. A local file inclusion is present in the NiceUI leaflet component when requesting resource files under the /nicegui/{version}/resources/{key}/{path:path} route. As a result any file on the backend filesystem which the web server has access to can be read by an attacker with access to the NiceUI leaflet website. This vulnerability has been addressed in version 1.4.21. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mwc7-64wg-pgvj
- Revision 1 · created ·
Published from osv record GHSA-mwc7-64wg-pgvj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-32005 Advisory: NiceGUI allows potential access to local file system IDs: CVE-2024-32005, GHSA-mwc7-64wg-pgvj Record: https://patchnext.com/advisories/cve-2024-32005 (revision 2, source checked 26 Oct 2026, 13:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nicegui 1.4.21. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI nicegui: affected >= 1.4.6, < 1.4.21; fixed in 1.4.21 ## Suggested inspection (read-only) - `python -m pip show nicegui`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nicegui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mwc7-64wg-pgvj (OSV record GHSA-mwc7-64wg-pgvj lists affected ranges: PyPI nicegui >=1.4.6 <1.4.21 (fixed)) - Verified: https://github.com/advisories/GHSA-mwc7-64wg-pgvj (GitHub-reviewed advisory GHSA-mwc7-64wg-pgvj lists affected ranges: PyPI nicegui >=1.4.6 <1.4.21) Commands are suggestions: review each one before running it.
Loading voting…