Skip to content

← Actionable
Critical, CVSS 10.0

XWiki Commons missing escaping of { in Velocity escapetool allows remote code execution

CVE-2024-31996GHSA-hf43-47q4-fhq5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.commons:xwiki-commons-velocity 15.9-rc-1, 15.5.4, 14.10.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-hf43-47q4-fhq5 lists affected ranges: Maven org.xwiki.commons:xwiki-commons-velocity >=3.0.1 =15.0-rc-1 =15.6-rc-1 <15.9-rc-1

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2024-31996: 2.10% estimated exploitation activity in the next 30 days; percentile 81.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The HTML escaping of escaping tool that is used in XWiki doesn't escape {, which, when used in certain places, allows XWiki syntax injection and thereby remote code execution. To reproduce in an XWiki installation, open <xwiki-host/xwiki/bin/view/Panels/PanelLayoutUpdate?place=%7B%7B%2Fhtml%7D%7D%7B%7Basync%20async%3Dfalse%7D%7D%7B%7Bvelocity%7D%7D%23evaluate(%24request.eval)%7B%7B%2Fvelocity%7D%7D%7B%7B%2Fasync%7D%7D&eval=Hello%20from%20URL%20Parameter!%20I%20got%20programming%3A%20%24services.security.authorization.hasAccess(%27programming%27) where <xwiki-host is the URL of your XWiki installation. If this displays You are not admin on this place Hello from URL Parameter! I got programming: true, the installation is vulnerable. Patches The vulnerability has been fixed on XWiki 14.10.19, 15.5.5, and 15.9 RC1. Workarounds Apart from upgrading, there is no generic workaround. However, replacing $escapetool.html by $escapetool.xml in XWiki documents fixes the vulnerability. In…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hf43-47q4-fhq5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-31996

Advisory: XWiki Commons missing escaping of `{` in Velocity escapetool allows remote code execution
IDs: CVE-2024-31996, GHSA-hf43-47q4-fhq5
Record: https://patchnext.com/advisories/cve-2024-31996 (revision 1, source checked 26 Oct 2026, 16:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.commons:xwiki-commons-velocity 15.9-rc-1, 15.5.4, 14.10.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.commons:xwiki-commons-velocity: affected >= 3.0.1, < 14.10.19; >= 15.0-rc-1, < 15.5.4; >= 15.6-rc-1, < 15.9-rc-1; fixed in 15.9-rc-1, 15.5.4, 14.10.19

## Suggested inspection (read-only)
- Maven org.xwiki.commons:xwiki-commons-velocity: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.commons:xwiki-commons-velocity.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hf43-47q4-fhq5 (GitHub-reviewed advisory GHSA-hf43-47q4-fhq5 lists affected ranges: Maven org.xwiki.commons:xwiki-commons-velocity >=3.0.1 =15.0-rc-1 =15.6-rc-1 <15.9-rc-1)

Commands are suggestions: review each one before running it.

Loading voting…