XWiki Platform CSRF remote code execution through the realtime HTML Converter API
CVE-2024-31988GHSA-r5vh-gc3r-r24w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-realtime-ui 15.9, 15.5.4, 14.10.19), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-realtime-ui
- Affected
- >= 13.9-rc-1, < 14.10.19>= 15.0-rc-1, < 15.5.4>= 15.6-rc-1, < 15.9
- Fixed in
- 15.9, 15.5.4, 14.10.19
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r5vh-gc3r-r24w lists affected ranges: Maven org.xwiki.platform:xwiki-platform-realtime-ui >=13.9-rc-1 =15.0-rc-1 =15.6-rc-1 <15.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2024-31988: 0.70% estimated exploitation activity in the next 30 days; percentile 53.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When the realtime editor is installed in XWiki, it allows arbitrary remote code execution with the interaction of an admin user with programming right. More precisely, by getting an admin user to either visit a crafted URL or to view an image with this URL that could be in a comment, the attacker can get the admin to execute arbitrary XWiki syntax including scripting macros with Groovy or Python code. This compromises the confidentiality, integrity and availability of the whole XWiki installation. To reproduce on an XWiki installation, as an admin, click on <xwiki-host/xwiki/bin/get/RTFrontend/ConvertHTML?wiki=xwiki&space=Main&page=WebHome&text=%7B%7Bvelocity%7D%7D%24logtool.error%28%22Hello%20from%20Velocity%20%21%22%29%7B%7B%2Fvelocity%7D%7D. If the error "Hello from Velocity!" gets logged then the installation is vulnerable. Patches This vulnerability has been patched in XWiki 14.10.19, 15.5.4 and 15.9. Workarounds Update RTFrontend.ConvertHTML following this patch. This…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r5vh-gc3r-r24w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-31988 Advisory: XWiki Platform CSRF remote code execution through the realtime HTML Converter API IDs: CVE-2024-31988, GHSA-r5vh-gc3r-r24w Record: https://patchnext.com/advisories/cve-2024-31988 (revision 1, source checked 26 Oct 2026, 16:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-realtime-ui 15.9, 15.5.4, 14.10.19. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-realtime-ui: affected >= 13.9-rc-1, < 14.10.19; >= 15.0-rc-1, < 15.5.4; >= 15.6-rc-1, < 15.9; fixed in 15.9, 15.5.4, 14.10.19 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-realtime-ui: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-realtime-ui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r5vh-gc3r-r24w (GitHub-reviewed advisory GHSA-r5vh-gc3r-r24w lists affected ranges: Maven org.xwiki.platform:xwiki-platform-realtime-ui >=13.9-rc-1 =15.0-rc-1 =15.6-rc-1 <15.9) Commands are suggestions: review each one before running it.
Loading voting…