XWiki Platform remote code execution from account via custom skins support
CVE-2024-31987GHSA-cv55-v6rw-7r5v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-oldcore 15.10-rc-1, 15.5.4, 14.10.19), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-oldcore
- Affected
- >= 6.4-milestone-1, < 14.10.19>= 15.0-rc-1, < 15.5.4>= 15.6-rc-1, < 15.10-rc-1
- Fixed in
- 15.10-rc-1, 15.5.4, 14.10.19
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cv55-v6rw-7r5v lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=6.4-milestone-1 =15.0-rc-1 =15.6-rc-1 <15.10-rc-1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2024-31987: 1.45% estimated exploitation activity in the next 30 days; percentile 73.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Any user who can edit any page like their profile can create a custom skin with a template override that is executed with programming right, thus allowing remote code execution. To reproduce, as a user without edit, script or admin right, add an object of class XWiki.XWikiSkins to your profile. Name it whatever you want and set the Base Skin to flamingo. Add an object of class XWikiSkinFileOverrideClass and set the path to macros.vm and the content to: Back to your profile, click Test this skin. Force a refresh, just in case. If the error "Skin - I got programming: true" gets logged, the installation is vulnerable. Patches This has been patched in XWiki 14.10.19, 15.5.4 and 15.10RC1. Workarounds We're not aware of any workaround except upgrading. References https://jira.xwiki.org/browse/XWIKI-21478 https://github.com/xwiki/xwiki-platform/commit/3d4dbb41f52d1a6e39835cfb1695ca6668605a39 (= 15.8 RC1)…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cv55-v6rw-7r5v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-31987 Advisory: XWiki Platform remote code execution from account via custom skins support IDs: CVE-2024-31987, GHSA-cv55-v6rw-7r5v Record: https://patchnext.com/advisories/cve-2024-31987 (revision 1, source checked 26 Oct 2026, 16:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-oldcore 15.10-rc-1, 15.5.4, 14.10.19. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-oldcore: affected >= 6.4-milestone-1, < 14.10.19; >= 15.0-rc-1, < 15.5.4; >= 15.6-rc-1, < 15.10-rc-1; fixed in 15.10-rc-1, 15.5.4, 14.10.19 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-oldcore: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-oldcore. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cv55-v6rw-7r5v (GitHub-reviewed advisory GHSA-cv55-v6rw-7r5v lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=6.4-milestone-1 =15.0-rc-1 =15.6-rc-1 <15.10-rc-1) Commands are suggestions: review each one before running it.
Loading voting…