Skip to content

← Actionable
Critical, CVSS 9.9

XWiki Platform: Privilege escalation (PR) from user registration through PDFClass

CVE-2024-31981GHSA-vxwr-wpjv-qjq7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-oldcore 15.10-rc-1, 15.5.4, 14.10.20), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-vxwr-wpjv-qjq7 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=3.0.1 =15.0-rc-1 =15.6-rc-1 <15.10-rc-1

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2024-31981: 1.45% estimated exploitation activity in the next 30 days; percentile 73.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Remote code execution is possible via PDF export templates. To reproduce on an installation, register a new user account with username PDFClass if XWiki.PDFClass does not exist. On XWiki.PDFClass, use the class editor to add a "style" property of type "TextArea" and content type "Plain Text". Then, add an object of class PDFClass and set the "style" attribute to $services.logging.getLogger('PDFClass').error("I got programming: $services.security.authorization.hasAccess('programming')"). Finally, go to <host/xwiki/bin/export/Main/WebHome?format=pdf&pdftemplate=XWiki.PDFClass. If the logs contain "ERROR PDFClass - I got programming: true", the instance is vulnerable. Patches This vulnerability has been patched in XWiki 14.10.20, 15.5.4 and 15.10-rc-1. Workarounds If PDF templates are not typically used on the instance, an administrator can create the document XWiki.PDFClass and block its edition, after making sure that it does not contain a style attribute. Otherwise, the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vxwr-wpjv-qjq7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-31981

Advisory: XWiki Platform: Privilege escalation (PR) from user registration through PDFClass
IDs: CVE-2024-31981, GHSA-vxwr-wpjv-qjq7
Record: https://patchnext.com/advisories/cve-2024-31981 (revision 1, source checked 26 Oct 2026, 16:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-oldcore 15.10-rc-1, 15.5.4, 14.10.20. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.platform:xwiki-platform-oldcore: affected >= 3.0.1, < 14.10.20; >= 15.0-rc-1, < 15.5.4; >= 15.6-rc-1, < 15.10-rc-1; fixed in 15.10-rc-1, 14.10.20, 15.5.4

## Suggested inspection (read-only)
- Maven org.xwiki.platform:xwiki-platform-oldcore: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.platform:xwiki-platform-oldcore.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vxwr-wpjv-qjq7 (GitHub-reviewed advisory GHSA-vxwr-wpjv-qjq7 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=3.0.1 =15.0-rc-1 =15.6-rc-1 <15.10-rc-1)

Commands are suggestions: review each one before running it.

Loading voting…