Skip to content

← Actionable
High, CVSS 8.7amended

PyTorch heap buffer overflow vulnerability

CVE-2024-31580GHSA-5pcm-hx3q-hm94

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (torch-npu 2.2.0; torch 2.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI torch-npu

    Affected
    < 2.2.0
    Fixed in
    2.2.0
  • PyPI torch

    Affected
    < 2.2.0
    Fixed in
    2.2.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-31580: 0.22% estimated exploitation activity in the next 30 days; percentile 13.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

PyTorch before v2.2.0 was discovered to contain a heap buffer overflow vulnerability in the component /runtime/varargfunctions.cpp. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted input.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-5pcm-hx3q-hm94

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record PYSEC-2024-328

  4. Revision 1 · created ·

    Published from osv record GHSA-5pcm-hx3q-hm94

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-31580

Advisory: PyTorch heap buffer overflow vulnerability
IDs: CVE-2024-31580, GHSA-5pcm-hx3q-hm94
Record: https://patchnext.com/advisories/cve-2024-31580 (revision 4, source checked 26 Oct 2026, 13:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: torch-npu 2.2.0; torch 2.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI torch-npu: affected < 2.2.0; fixed in 2.2.0
- PyPI torch: affected < 2.2.0; fixed in 2.2.0

## Suggested inspection (read-only)
- `python -m pip show torch-npu`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show torch`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on torch-npu, torch.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5pcm-hx3q-hm94 (OSV record GHSA-5pcm-hx3q-hm94 lists affected ranges: PyPI torch >=0 <2.2.0 (fixed))
- Verified: https://osv.dev/vulnerability/PYSEC-2024-328 (OSV record PYSEC-2024-328 lists affected ranges: PyPI torch-npu >=0 <2.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-5pcm-hx3q-hm94 (GitHub-reviewed advisory GHSA-5pcm-hx3q-hm94 lists affected ranges: PyPI torch >=0 <2.2.0)

Commands are suggestions: review each one before running it.

Loading voting…