XMLUnit for Java has Insecure Defaults when Processing XSLT Stylesheets
CVE-2024-31573GHSA-chfm-68vv-pvw5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xmlunit:xmlunit-core 2.10.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xmlunit:xmlunit-core
- Affected
- < 2.10.0
- Fixed in
- 2.10.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-chfm-68vv-pvw5 lists affected ranges: Maven org.xmlunit:xmlunit-core >=0 <2.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2024-31573: 0.32% estimated exploitation activity in the next 30 days; percentile 25.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When performing XSLT transformations XMLUnit for Java did not disable XSLT extension functions by default. Depending on the XSLT processor being used this could allow arbitrary code to be executed when XMLUnit is used to transform data with a stylesheet who's source can not be trusted. If the stylesheet can be provided externally this may even lead to a remote code execution. Patches Users are advised to upgrade to XMLUnit for Java 2.10.0 where the default has been changed by means of https://github.com/xmlunit/xmlunit/commit/b81d48b71dfd2868bdfc30a3e17ff973f32bc15b Workarounds XMLUnit's main use-case is performing tests on code that generates or processes XML. Most users will not use it to perform arbitrary XSLT transformations. Users running XSLT transformations with untrusted stylesheets should explicitly use XMLUnit's APIs to pass in a pre-configured TraX TransformerFactory with extension functions disabled via features and attributes. The required setFactory or…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-chfm-68vv-pvw5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-31573 Advisory: XMLUnit for Java has Insecure Defaults when Processing XSLT Stylesheets IDs: CVE-2024-31573, GHSA-chfm-68vv-pvw5 Record: https://patchnext.com/advisories/cve-2024-31573 (revision 1, source checked 26 Oct 2026, 16:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xmlunit:xmlunit-core 2.10.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xmlunit:xmlunit-core: affected < 2.10.0; fixed in 2.10.0 ## Suggested inspection (read-only) - Maven org.xmlunit:xmlunit-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xmlunit:xmlunit-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-chfm-68vv-pvw5 (GitHub-reviewed advisory GHSA-chfm-68vv-pvw5 lists affected ranges: Maven org.xmlunit:xmlunit-core >=0 <2.10.0) Commands are suggestions: review each one before running it.
Loading voting…