CRI-O vulnerable to an arbitrary systemd property injection
CVE-2024-3154GHSA-2cgq-h8xw-2v5j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/cri-o/cri-o 1.29.4, 1.28.6, 1.27.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.29.0, <= 1.29.3>= 1.28.0, <= 1.28.5<= 1.27.5
- Fixed in
- 1.27.6, 1.28.6, 1.29.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2cgq-h8xw-2v5j lists affected ranges: Go github.com/cri-o/cri-o >=1.29.0 =1.28.0 =0 <=1.27.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2024-3154: 1.42% estimated exploitation activity in the next 30 days; percentile 72.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact On CRI-O, it looks like an arbitrary systemd property can be injected via a Pod annotation: This means that any user who can create a pod with an arbitrary annotation may perform an arbitrary action on the host system. Tested with CRI-O v1.24 on minikube. I didn't test the latest v1.29 because it is incompatible with minikube: https://github.com/kubernetes/minikube/pull/18367 Thanks to Cédric Clerget (GitHub ID @cclerget) for finding out that CRI-O just passes pod annotations to OCI annotations: https://github.com/opencontainers/runc/pull/3923#discussionr1532292536 CRI-O has to filter out annotations that have the prefix "org.systemd.property." See also: - https://github.com/opencontainers/runtime-spec/blob/main/features.md#unsafe-annotations-in-configjson - https://github.com/opencontainers/runc/pull/4217 Workarounds Unfortunately, the only workarounds would involve an external mutating webhook to disallow these annotations References
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2cgq-h8xw-2v5j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-3154 Advisory: CRI-O vulnerable to an arbitrary systemd property injection IDs: CVE-2024-3154, GHSA-2cgq-h8xw-2v5j Record: https://patchnext.com/advisories/cve-2024-3154 (revision 1, source checked 26 Oct 2026, 15:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/cri-o/cri-o 1.29.4, 1.28.6, 1.27.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/cri-o/cri-o: affected >= 1.29.0, <= 1.29.3; >= 1.28.0, <= 1.28.5; <= 1.27.5; fixed in 1.27.6, 1.28.6, 1.29.4 ## Suggested inspection (read-only) - Go github.com/cri-o/cri-o: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/cri-o/cri-o. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2cgq-h8xw-2v5j (GitHub-reviewed advisory GHSA-2cgq-h8xw-2v5j lists affected ranges: Go github.com/cri-o/cri-o >=1.29.0 =1.28.0 =0 <=1.27.5) Commands are suggestions: review each one before running it.
Loading voting…