XWiki Platform: Password hash might be leaked by diff once the xobject holding them is deleted
CVE-2024-31464GHSA-v782-xr4w-3vqx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-oldcore 15.9-rc-1, 15.5.4, 14.10.19), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-oldcore
- Affected
- >= 5.0-rc-1, < 14.10.19>= 15.0-rc-1, < 15.5.4>= 15.6-rc-1, < 15.9-rc-1
- Fixed in
- 15.9-rc-1, 15.5.4, 14.10.19
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v782-xr4w-3vqx lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=5.0-rc-1 =15.0-rc-1 =15.6-rc-1 <15.9-rc-1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2024-31464: 0.38% estimated exploitation activity in the next 30 days; percentile 31.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact It is possible to access the hash of a password by using the diff feature of the history whenever the object storing the password is deleted. Using that vulnerability it's possible for an attacker to have access to the hash password of a user if they have rights to edit the users' page. Now with the default right scheme in XWiki this vulnerability is normally prevented on user profiles, except by users with Admin rights. Note that this vulnerability also impacts any extensions that might use passwords stored in xobjects: for those usecases it depends on the right of those pages. There is currently no way to be 100% sure that this vulnerability has been exploited, as an attacker with enough privilege could have deleted the revision where the xobject was deleted after rolling-back the deletion. But again, this operation requires high privileges on the target page (Admin right). A page with a user password xobject which have in its history a revision where the object has been…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v782-xr4w-3vqx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-31464 Advisory: XWiki Platform: Password hash might be leaked by diff once the xobject holding them is deleted IDs: CVE-2024-31464, GHSA-v782-xr4w-3vqx Record: https://patchnext.com/advisories/cve-2024-31464 (revision 1, source checked 26 Oct 2026, 16:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-oldcore 15.9-rc-1, 15.5.4, 14.10.19. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-oldcore: affected >= 5.0-rc-1, < 14.10.19; >= 15.0-rc-1, < 15.5.4; >= 15.6-rc-1, < 15.9-rc-1; fixed in 15.9-rc-1, 15.5.4, 14.10.19 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-oldcore: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-oldcore. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v782-xr4w-3vqx (GitHub-reviewed advisory GHSA-v782-xr4w-3vqx lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=5.0-rc-1 =15.0-rc-1 =15.6-rc-1 <15.9-rc-1) Commands are suggestions: review each one before running it.
Loading voting…