Skip to content

← Actionable
High, CVSS 7.7

gin-vue-admin background arbitrary code coverage vulnerability

CVE-2024-31457GHSA-gv3w-m57p-3wc4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/flipped-aurora/gin-vue-admin/server 0.0.0-20240409100909-b1b7427c6ea6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-gv3w-m57p-3wc4 lists affected ranges: Go github.com/flipped-aurora/gin-vue-admin/server >=0 <0.0.0-20240409100909-b1b7427c6ea6

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:N/I:H/A:H
EPSS
  • CVE-2024-31457: 0.90% estimated exploitation activity in the next 30 days; percentile 59.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact "gin-vue-admin<=v2.6.1 has a code injection vulnerability in the backend. In the Plugin System - Plugin Template feature, an attacker can perform directory traversal by manipulating the 'plugName' parameter. They can create specific folders such as 'api', 'config', 'global', 'model', 'router', 'service', and 'main.go' function within the specified traversal directory. Moreover, the Go files within these folders can have arbitrary code inserted based on a specific PoC parameter." Affected code: https://github.com/flipped-aurora/gin-vue-admin/blob/746af378990ebf3367f8bb3d4e9684936df152e7/server/api/v1/system/sysautocode.go:239. Let's take a look at the method 'AutoPlug' within the 'AutoCodeApi' struct. The main reason for the existence of this vulnerability is the controllability of the PlugName field within the struct. POC: By performing directory traversal and creating directories such as api, config, global, model, router, and service within the gin-vue-admin/server…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gv3w-m57p-3wc4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-31457

Advisory: gin-vue-admin background arbitrary code coverage vulnerability
IDs: CVE-2024-31457, GHSA-gv3w-m57p-3wc4
Record: https://patchnext.com/advisories/cve-2024-31457 (revision 1, source checked 26 Oct 2026, 15:03 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/flipped-aurora/gin-vue-admin/server 0.0.0-20240409100909-b1b7427c6ea6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/flipped-aurora/gin-vue-admin/server: affected < 0.0.0-20240409100909-b1b7427c6ea6; fixed in 0.0.0-20240409100909-b1b7427c6ea6

## Suggested inspection (read-only)
- Go github.com/flipped-aurora/gin-vue-admin/server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/flipped-aurora/gin-vue-admin/server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gv3w-m57p-3wc4 (GitHub-reviewed advisory GHSA-gv3w-m57p-3wc4 lists affected ranges: Go github.com/flipped-aurora/gin-vue-admin/server >=0 <0.0.0-20240409100909-b1b7427c6ea6)

Commands are suggestions: review each one before running it.

Loading voting…