Skip to content

← Actionable
Medium, CVSS 6.5amended

PsiTransfer: File integrity violation

CVE-2024-31454GHSA-2p2x-p7wj-j5h2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (psitransfer 2.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
EPSS
  • CVE-2024-31454: 0.52% estimated exploitation activity in the next 30 days; percentile 44.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The absence of restrictions on the endpoint, which is designed for uploading files, allows an attacker who received the id of a file distribution to change the files that are in this distribution. Details Vulnerable endpoint: PATCH /files/{{id}} PoC 1. Create a file distribution. 2. Go to the link address for downloading files and download the file (in this case, the attacker receives the file id from the download request). 3. Send a PATCH /files/{{id}} request with arbitrary content in the request body. Thus, the file with the specified id will be changed. What the attacker specifies in the body of the request will be added to the end of the original content. In the future, users will download the modified file. Impact The vulnerability allows an attacker to influence those users who come to the file distribution after him and slip the victim files with a malicious or phishing signature.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2p2x-p7wj-j5h2

  2. Revision 1 · created ·

    Published from osv record GHSA-2p2x-p7wj-j5h2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-31454

Advisory: PsiTransfer: File integrity violation
IDs: CVE-2024-31454, GHSA-2p2x-p7wj-j5h2
Record: https://patchnext.com/advisories/cve-2024-31454 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: psitransfer 2.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm psitransfer: affected < 2.2.0; fixed in 2.2.0

## Suggested inspection (read-only)
- `npm ls psitransfer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on psitransfer.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2p2x-p7wj-j5h2 (OSV record GHSA-2p2x-p7wj-j5h2 lists affected ranges: npm psitransfer >=0 <2.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-2p2x-p7wj-j5h2 (GitHub-reviewed advisory GHSA-2p2x-p7wj-j5h2 lists affected ranges: npm psitransfer >=0 <2.2.0)

Commands are suggestions: review each one before running it.

Loading voting…