PsiTransfer: Violation of the integrity of file distribution
CVE-2024-31453GHSA-xg8v-m2mh-45m6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (psitransfer 2.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm psitransfer
- Affected
- < 2.2.0
- Fixed in
- 2.2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xg8v-m2mh-45m6 lists affected ranges: npm psitransfer >=0 <2.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xg8v-m2mh-45m6 lists affected ranges: npm psitransfer >=0 <2.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- EPSS
- CVE-2024-31453: 0.52% estimated exploitation activity in the next 30 days; percentile 44.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The absence of restrictions on the endpoint, which allows you to create a path for uploading a file in a file distribution, allows an attacker to add arbitrary files to the distribution. Details Vulnerable endpoint: POST /files PoC 1. Create a file distribution. <img width="1434" alt="Снимок экрана 2024-03-17 в 21 27 30" src="https://github.com/psi-4ward/psitransfer/assets/163760990/4634a6f7-6e7d-486e-9929-76156aaa1340" 2. Go to the link address (id of the file distribution is needed by an attacker to upload files there). <img width="1426" alt="Снимок экрана 2024-03-17 в 21 27 35" src="https://github.com/psi-4ward/psitransfer/assets/163760990/a57c910c-69e2-4b07-985d-b0a46c69891a" 3. Send a POST /files. As the value of the Upload-Metadata header we specify the sid parameter with the id of the file distribution obtained in the second step. In the response from the server in the Location header we get the path for uploading a new file to the file distribution. <img width="1403"…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xg8v-m2mh-45m6
- Revision 1 · created ·
Published from osv record GHSA-xg8v-m2mh-45m6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-31453 Advisory: PsiTransfer: Violation of the integrity of file distribution IDs: CVE-2024-31453, GHSA-xg8v-m2mh-45m6 Record: https://patchnext.com/advisories/cve-2024-31453 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: psitransfer 2.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm psitransfer: affected < 2.2.0; fixed in 2.2.0 ## Suggested inspection (read-only) - `npm ls psitransfer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on psitransfer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xg8v-m2mh-45m6 (OSV record GHSA-xg8v-m2mh-45m6 lists affected ranges: npm psitransfer >=0 <2.2.0 (fixed)) - Verified: https://github.com/advisories/GHSA-xg8v-m2mh-45m6 (GitHub-reviewed advisory GHSA-xg8v-m2mh-45m6 lists affected ranges: npm psitransfer >=0 <2.2.0) Commands are suggestions: review each one before running it.
Loading voting…