Skip to content

← Actionable
Medium, CVSS 5.3amended

Information Disclosure Vulnerability in Privacy Center of SERVER_SIDE_FIDES_API_URL

CVE-2024-31223GHSA-53q7-4874-24qg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ethyca-fides 2.39.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2024-31223: 1.10% estimated exploitation activity in the next 30 days; percentile 65.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

SERVERSIDEFIDESAPIURL is a server-side configuration environment variable used by the Fides Privacy Center to communicate with the Fides webserver backend. The value of this variable is a URL which typically includes a private IP address, private domain name, and/or port. This vulnerability allows an unauthenticated attacker to make a HTTP GET request from the Privacy Center that discloses the value of this server-side URL. Impact Disclosure of server-side configuration giving an attacker information on server-side ports, private IP addresses, and/or private domain names. Patches The vulnerability has been patched in Fides version 2.39.2. Users are advised to upgrade to this version or later to secure their systems against this threat. Workarounds There are no workarounds. Proof of Concept 1. Set the value of the environment variable FIDESPRIVACYCENTERSERVERSIDEFIDESAPIURL of your Fides Privacy Center container before start-up to a private value such as…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-53q7-4874-24qg

  2. Revision 1 · created ·

    Published from osv record GHSA-53q7-4874-24qg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-31223

Advisory: Information Disclosure Vulnerability in Privacy Center of SERVER_SIDE_FIDES_API_URL
IDs: CVE-2024-31223, GHSA-53q7-4874-24qg
Record: https://patchnext.com/advisories/cve-2024-31223 (revision 2, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ethyca-fides 2.39.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ethyca-fides: affected >= 2.19.0, < 2.39.2; fixed in 2.39.2

## Suggested inspection (read-only)
- `python -m pip show ethyca-fides`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ethyca-fides.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-53q7-4874-24qg (OSV record GHSA-53q7-4874-24qg lists affected ranges: PyPI ethyca-fides >=2.19.0 <2.39.2 (fixed))
- Verified: https://github.com/advisories/GHSA-53q7-4874-24qg (GitHub-reviewed advisory GHSA-53q7-4874-24qg lists affected ranges: PyPI ethyca-fides >=2.19.0 <2.39.2)

Commands are suggestions: review each one before running it.

Loading voting…