Skip to content

← Actionable
Medium, CVSS 5.3amended

@strapi/plugin-upload has a Denial-of-Service via Improper Exception Handling

CVE-2024-31217GHSA-pm9q-xj9p-96pm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@strapi/plugin-upload 4.22.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2024-31217: 0.74% estimated exploitation activity in the next 30 days; percentile 54.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Denial-of-Service was found in the media upload process causing the server to crash without restarting, affecting either development and production environments. Details Usually, errors in the application cause it to log the error and keep it running for other clients. This behavior, in contrast, stops the server execution, making it unavailable for any clients until it's manually restarted. PoC Due to a bug in what we believe to be Burp’s decoding system, we couldn’t produce a valid file to easily reproduce the vulnerability. Instead, the issue can be reproduced by following these steps: 1. Configure Burp’s proxy between a browser and a Strapi server 2. Log in and upload an image through the Media Library page while having Burp’s interceptor turned on 3. After capturing the upload POST request in Burp, add %00 at the end of the file extension from the Content-Disposition, in the filename parameter (See reference image 1 below) 4. Using the cursor, select the added %00 and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pm9q-xj9p-96pm

  2. Revision 1 · created ·

    Published from osv record GHSA-pm9q-xj9p-96pm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-31217

Advisory: @strapi/plugin-upload has a Denial-of-Service via Improper Exception Handling
IDs: CVE-2024-31217, GHSA-pm9q-xj9p-96pm
Record: https://patchnext.com/advisories/cve-2024-31217 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @strapi/plugin-upload 4.22.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @strapi/plugin-upload: affected < 4.22.0; fixed in 4.22.0

## Suggested inspection (read-only)
- `npm ls @strapi/plugin-upload --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @strapi/plugin-upload.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pm9q-xj9p-96pm (OSV record GHSA-pm9q-xj9p-96pm lists affected ranges: npm @strapi/plugin-upload >=0 <4.22.0 (fixed))
- Verified: https://github.com/advisories/GHSA-pm9q-xj9p-96pm (GitHub-reviewed advisory GHSA-pm9q-xj9p-96pm lists affected ranges: npm @strapi/plugin-upload >=0 <4.22.0)

Commands are suggestions: review each one before running it.

Loading voting…