Skip to content

← Actionable
Medium, CVSS 6.5amended

Synapse V2 state resolution weakness allows Denial of Service (DoS)

CVE-2024-31208GHSA-3h7q-rfh9-xm4v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (matrix-synapse 1.105.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2024-31208: 1.46% estimated exploitation activity in the next 30 days; percentile 73.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A remote Matrix user with malicious intent, sharing a room with Synapse instances before 1.105.1, can dispatch specially crafted events to exploit a weakness in how the auth chain cover index is calculated. This can induce high CPU consumption and accumulate excessive data in the database of such instances, resulting in a denial of service. Servers in private federations, or those that do not federate, are not affected. Patches Server administrators should upgrade to 1.105.1 or later. Workarounds One can: - ban the malicious users or ACL block servers from the rooms; and/or - leave the room and purge the room using the admin API For more information If you have any questions or comments about this advisory, please email us at security AT element.io.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3h7q-rfh9-xm4v

  2. Revision 1 · created ·

    Published from osv record GHSA-3h7q-rfh9-xm4v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-31208

Advisory: Synapse V2 state resolution weakness allows Denial of Service (DoS)
IDs: CVE-2024-31208, GHSA-3h7q-rfh9-xm4v
Record: https://patchnext.com/advisories/cve-2024-31208 (revision 2, source checked 26 Oct 2026, 13:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: matrix-synapse 1.105.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI matrix-synapse: affected < 1.105.1; fixed in 1.105.1

## Suggested inspection (read-only)
- `python -m pip show matrix-synapse`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on matrix-synapse.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3h7q-rfh9-xm4v (OSV record GHSA-3h7q-rfh9-xm4v lists affected ranges: PyPI matrix-synapse >=0 <1.105.1 (fixed))
- Verified: https://github.com/advisories/GHSA-3h7q-rfh9-xm4v (GitHub-reviewed advisory GHSA-3h7q-rfh9-xm4v lists affected ranges: PyPI matrix-synapse >=0 <1.105.1)

Commands are suggestions: review each one before running it.

Loading voting…