Skip to content

← Actionable
Low, CVSS 3.3amended

Wasmtime vulnerable to panic when using a dropped extenref-typed element segment

CVE-2024-30266GHSA-75hq-h6g9-h4q5

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI wasmtime

    Affected
    <= 19.0.0
    Fixed in
    no fixed version recorded
  • crates.io wasmtime

    Affected
    >= 19.0.0, <= 19.0.0
    Fixed in
    19.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.3 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2024-30266: 0.32% estimated exploitation activity in the next 30 days; percentile 25.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The 19.0.0 release of Wasmtime contains a regression introduced during its development which can lead to a guest WebAssembly module causing a panic in the host runtime. A valid WebAssembly module, when executed at runtime, may cause this panic. The panic in question is caused when a WebAssembly module issues a table. instruction which uses a dropped element segment with a table that also has an externref type. This causes Wasmtime to erroneously use an empty function segment instead of an empty externref segment to perform this operation. This mismatch in types causes a panic in Wasmtime when it's asserted that an externref table is only viewed as externrefs. This regression was introduced during the development of the 19.0.0 release and only affects the 19.0.0 release. This panic requires the reference-types WebAssembly feature to be enabled, and it is enabled by default. Toolchains are not known to generate this pattern by default so it's likely a module would need to be…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-75hq-h6g9-h4q5

  2. Revision 1 · created ·

    Published from osv record PYSEC-2024-327

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-30266

Advisory: Wasmtime vulnerable to panic when using a dropped extenref-typed element segment
IDs: CVE-2024-30266, GHSA-75hq-h6g9-h4q5
Record: https://patchnext.com/advisories/cve-2024-30266 (revision 2, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: wasmtime 19.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI wasmtime: affected <= 19.0.0
- crates.io wasmtime: affected >= 19.0.0, <= 19.0.0; fixed in 19.0.1

## Suggested inspection (read-only)
- `python -m pip show wasmtime`: prints the installed version. Run with the environment that serves production active.
- crates.io wasmtime: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wasmtime.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/PYSEC-2024-327 (OSV record PYSEC-2024-327 lists affected ranges: PyPI wasmtime >=0 <=19.0.0)
- Verified: https://github.com/advisories/GHSA-75hq-h6g9-h4q5 (GitHub-reviewed advisory GHSA-75hq-h6g9-h4q5 lists affected ranges: crates.io wasmtime >=19.0.0 <=19.0.0)

Commands are suggestions: review each one before running it.

Loading voting…