Voilà Local file inclusion
CVE-2024-30265GHSA-2q59-h24c-w6fg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (voila 0.5.6, 0.4.4, 0.3.8, 0.2.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI voila
- Affected
- >= 0.0.2, < 0.2.17>= 0.3.0a0, < 0.3.8>= 0.4.0a0, < 0.4.4>= 0.5.0a0, < 0.5.6
- Fixed in
- 0.2.17, 0.5.6, 0.4.4, 0.3.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2q59-h24c-w6fg lists affected ranges: PyPI voila >=0.0.2 =0.3.0a0 =0.4.0a0 =0.5.0a0 <0.5.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2q59-h24c-w6fg lists affected ranges: PyPI voila >=0.0.2 =0.3.0a0 =0.4.0a0 =0.5.0a0 <0.5.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2024-30265: 0.73% estimated exploitation activity in the next 30 days; percentile 54.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Any deployment of voilà dashboard allow local file inclusion, that is to say any file on a filesystem that is readable by the user that runs the voilà dashboard server can be downloaded by someone with network access to the server. Whether this still requires authentication depends on how voilà is deployed. Patches This is patched in 0.2.17+, 0.3.8+, 0.4.4+, 0.5.6+ Workarounds None. References CWE-73: External Control of File Name or Path Original report I have found a local file inclusion vulnerability in one of your subprojects, voila (https://github.com/voila-dashboards/voila). The vulnerability exists in the "/static" Route, and can be exploited by simply making a request such as this: ...or by using a webbrowser to download the file. I dug into the source code, and I think the offending line is here: https://github.com/voila-dashboards/voila/blob/8419cc7d79c0bb1dabfbd9ec49cb957740609d4d/voila/app.py#L664 "staticpath" gets set to "/", irrespective of the actual "--static"…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-2q59-h24c-w6fg
- Revision 1 · created ·
Published from osv record GHSA-2q59-h24c-w6fg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-30265 Advisory: Voilà Local file inclusion IDs: CVE-2024-30265, GHSA-2q59-h24c-w6fg Record: https://patchnext.com/advisories/cve-2024-30265 (revision 2, source checked 26 Oct 2026, 13:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: voila 0.5.6, 0.4.4, 0.3.8, 0.2.17. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI voila: affected >= 0.0.2, < 0.2.17; >= 0.3.0a0, < 0.3.8; >= 0.4.0a0, < 0.4.4; >= 0.5.0a0, < 0.5.6; fixed in 0.2.17, 0.5.6, 0.4.4, 0.3.8 ## Suggested inspection (read-only) - `python -m pip show voila`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on voila. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2q59-h24c-w6fg (OSV record GHSA-2q59-h24c-w6fg lists affected ranges: PyPI voila >=0.0.2 =0.3.0a0 =0.4.0a0 =0.5.0a0 <0.5.6 (fixed)) - Verified: https://github.com/advisories/GHSA-2q59-h24c-w6fg (GitHub-reviewed advisory GHSA-2q59-h24c-w6fg lists affected ranges: PyPI voila >=0.0.2 =0.3.0a0 =0.4.0a0 =0.5.0a0 <0.5.6) Commands are suggestions: review each one before running it.
Loading voting…