Skip to content

← Actionable
High, CVSS 7.5amended

aiohttp vulnerable to Denial of Service when trying to parse malformed POST requests

CVE-2024-30251GHSA-5m98-qgg9-wh84

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (aiohttp 3.9.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI aiohttp

    Affected
    < 3.9.4
    Fixed in
    3.9.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2024-30251: 1.09% estimated exploitation activity in the next 30 days; percentile 65.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An attacker can send a specially crafted POST (multipart/form-data) request. When the aiohttp server processes it, the server will enter an infinite loop and be unable to process any further requests. Impact An attacker can stop the application from serving requests after sending a single request. ------- For anyone needing to patch older versions of aiohttp, the minimum diff needed to resolve the issue is (located in readchunkfromlength()): This does however introduce some very minor issues with handling form data. So, if possible, it would be recommended to also backport the changes in: https://github.com/aio-libs/aiohttp/commit/cebe526b9c34dc3a3da9140409db63014bc4cf19 https://github.com/aio-libs/aiohttp/commit/7eecdff163ccf029fbb1ddc9de4169d4aaeb6597 https://github.com/aio-libs/aiohttp/commit/f21c6f2ca512a026ce7f0f6c6311f62d6a638866

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5m98-qgg9-wh84

  2. Revision 1 · created ·

    Published from osv record GHSA-5m98-qgg9-wh84

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-30251

Advisory: aiohttp vulnerable to Denial of Service when trying to parse malformed POST requests
IDs: CVE-2024-30251, GHSA-5m98-qgg9-wh84
Record: https://patchnext.com/advisories/cve-2024-30251 (revision 2, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: aiohttp 3.9.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI aiohttp: affected < 3.9.4; fixed in 3.9.4

## Suggested inspection (read-only)
- `python -m pip show aiohttp`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on aiohttp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5m98-qgg9-wh84 (OSV record GHSA-5m98-qgg9-wh84 lists affected ranges: PyPI aiohttp >=0 <3.9.4 (fixed))
- Verified: https://github.com/advisories/GHSA-5m98-qgg9-wh84 (GitHub-reviewed advisory GHSA-5m98-qgg9-wh84 lists affected ranges: PyPI aiohttp >=0 <3.9.4)

Commands are suggestions: review each one before running it.

Loading voting…