OpenID Connect Authentication (oidc) Typo3 extension Authentication Bypass
CVE-2024-30173GHSA-hhf8-f5w9-g6vh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (causal/oidc 2.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist causal/oidc
- Affected
- < 2.1.0
- Fixed in
- 2.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hhf8-f5w9-g6vh lists affected ranges: Packagist causal/oidc >=0 <2.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N/E:F/RL:O/RC:C
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
The authentication service of the extension does not verify the OpenID Connect authentication state from the user lookup chain. Instead, the authentication service authenticates every valid frontend user from the user lookup chain, where the frontend user field “txoidc” is not empty. In scenarios, where either ext:felogin is active or where $GLOBALS['TYPO3CONFVARS'][‘FE’][‘checkFeUserPid’] is disabled, an attacker can login to OpenID Connect frontend user accounts by providing a valid username and any password.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hhf8-f5w9-g6vh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-30173 Advisory: OpenID Connect Authentication (oidc) Typo3 extension Authentication Bypass IDs: CVE-2024-30173, GHSA-hhf8-f5w9-g6vh Record: https://patchnext.com/advisories/cve-2024-30173 (revision 1, source checked 26 Oct 2026, 14:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: causal/oidc 2.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist causal/oidc: affected < 2.1.0; fixed in 2.1.0 ## Suggested inspection (read-only) - Packagist causal/oidc: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on causal/oidc. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hhf8-f5w9-g6vh (GitHub-reviewed advisory GHSA-hhf8-f5w9-g6vh lists affected ranges: Packagist causal/oidc >=0 <2.1.0) Commands are suggestions: review each one before running it.
Loading voting…