@workos-inc/authkit-nextjs session replay vulnerability
CVE-2024-29901GHSA-35w3-6qhc-474v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@workos-inc/authkit-nextjs 0.4.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @workos-inc/authkit-nextjs
- Affected
- < 0.4.2
- Fixed in
- 0.4.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-35w3-6qhc-474v lists affected ranges: npm @workos-inc/authkit-nextjs >=0 <0.4.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-35w3-6qhc-474v lists affected ranges: npm @workos-inc/authkit-nextjs >=0 <0.4.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2024-29901: 0.66% estimated exploitation activity in the next 30 days; percentile 51.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A user can reuse an expired session by controlling the x-workos-session header. Patches Patched in https://github.com/workos/authkit-nextjs/releases/tag/v0.4.2
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-35w3-6qhc-474v
- Revision 1 · created ·
Published from osv record GHSA-35w3-6qhc-474v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-29901 Advisory: @workos-inc/authkit-nextjs session replay vulnerability IDs: CVE-2024-29901, GHSA-35w3-6qhc-474v Record: https://patchnext.com/advisories/cve-2024-29901 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @workos-inc/authkit-nextjs 0.4.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @workos-inc/authkit-nextjs: affected < 0.4.2; fixed in 0.4.2 ## Suggested inspection (read-only) - `npm ls @workos-inc/authkit-nextjs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @workos-inc/authkit-nextjs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-35w3-6qhc-474v (OSV record GHSA-35w3-6qhc-474v lists affected ranges: npm @workos-inc/authkit-nextjs >=0 <0.4.2 (fixed)) - Verified: https://github.com/advisories/GHSA-35w3-6qhc-474v (GitHub-reviewed advisory GHSA-35w3-6qhc-474v lists affected ranges: npm @workos-inc/authkit-nextjs >=0 <0.4.2) Commands are suggestions: review each one before running it.
Loading voting…