Saleor: Customers' addresses leak when using Warehouse as a Pickup: Local stock only delivery method
CVE-2024-29888GHSA-mrj3-f2h4-7w45
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (saleor 3.19.15, 3.18.28, 3.17.32, 3.16.34, 3.15.37, 3.14.61), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI saleor
- Affected
- >= 3.14.56, < 3.14.61>= 3.15.31, < 3.15.37>= 3.16.27, < 3.16.34>= 3.17.25, < 3.17.32>= 3.18.19, < 3.18.28>= 3.19.5, < 3.19.15
- Fixed in
- 3.19.15, 3.15.37, 3.14.61, 3.16.34, 3.18.28, 3.17.32
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mrj3-f2h4-7w45 lists affected ranges: PyPI saleor >=3.14.56 =3.15.31 =3.16.27 =3.17.25 =3.18.19 =3.19.5 <3.19.15 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mrj3-f2h4-7w45 lists affected ranges: PyPI saleor >=3.14.56 =3.15.31 =3.16.27 =3.17.25 =3.18.19 =3.19.5 <3.19.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.2 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N
- EPSS
- CVE-2024-29888: 0.53% estimated exploitation activity in the next 30 days; percentile 45.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Using Pickup: Local stock only as a click-and-collect points could cause a leak of customer addresses Details When using Pickup: Local stock only click-and-collect as a delivery method in specific conditions the customer could overwrite the warehouse address with its own, which exposes its address as click-and-collect address. Impact The vulnerability can cause the leak of customer's address when using click-and-collect delivery option marked as Local stock only. It has impact on all orders with click-and-collect delivery method marked as Pickup:Local stock only The affected versions: =3.14.56 <3.14.61, =3.15.31 <3.15.37, =3.16.27 <3.16.34, =3.17.25 <3.17.32, =3.18.19 <3.18.28, =3.19.5 <3.19.15 This issue has been patched in versions: 3.14.61, 3.15.37, 3.16.34, 3.17.32, 3.18.28, 3.19.15 Workaround We strongly recommend upgrading to the latest versions, in case of inability to upgrade straight away, possible workarounds are: - turn off click-and-collect delivery method on…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mrj3-f2h4-7w45
- Revision 1 · created ·
Published from osv record GHSA-mrj3-f2h4-7w45
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-29888 Advisory: Saleor: Customers' addresses leak when using Warehouse as a `Pickup: Local stock only` delivery method IDs: CVE-2024-29888, GHSA-mrj3-f2h4-7w45 Record: https://patchnext.com/advisories/cve-2024-29888 (revision 2, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: saleor 3.19.15, 3.18.28, 3.17.32, 3.16.34, 3.15.37, 3.14.61. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI saleor: affected >= 3.14.56, < 3.14.61; >= 3.15.31, < 3.15.37; >= 3.16.27, < 3.16.34; >= 3.17.25, < 3.17.32; >= 3.18.19, < 3.18.28; >= 3.19.5, < 3.19.15; fixed in 3.19.15, 3.15.37, 3.14.61, 3.16.34, 3.18.28, 3.17.32 ## Suggested inspection (read-only) - `python -m pip show saleor`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on saleor. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mrj3-f2h4-7w45 (OSV record GHSA-mrj3-f2h4-7w45 lists affected ranges: PyPI saleor >=3.14.56 =3.15.31 =3.16.27 =3.17.25 =3.18.19 =3.19.5 <3.19.15 (fixed)) - Verified: https://github.com/advisories/GHSA-mrj3-f2h4-7w45 (GitHub-reviewed advisory GHSA-mrj3-f2h4-7w45 lists affected ranges: PyPI saleor >=3.14.56 =3.15.31 =3.16.27 =3.17.25 =3.18.19 =3.19.5 <3.19.15) Commands are suggestions: review each one before running it.
Loading voting…