Skip to content

← Actionable
Medium, CVSS 4.3amended

TinyMCE Cross-Site Scripting (XSS) vulnerability in handling external SVG files through Object or Embed elements

CVE-2024-29881GHSA-5359-pvf2-pw78

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tinymce 7.0.0; tinymce/tinymce 7.0.0; tinymce 7.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
EPSS
  • CVE-2024-29881: 0.71% estimated exploitation activity in the next 30 days; percentile 53.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content loading and content inserting code. A SVG image could be loaded though an object or embed element and that image could potentially contain a XSS payload. Fix TinyMCE 6.8.1 introduced a new convertunsafeembeds option to automatically convert object and embed elements respective of their type attribute. From TinyMCE 7.0.0 onwards, the convertunsafeembeds option is enabled by default. Workarounds If you are using TinyMCE 6.8.1 or higher, set convertunsafeembeds to true. For any earlier versions, a custom NodeFilter is recommended to remove or modify any object or embed elements. This can be added using the editor.parser.addNodeFilter and editor.serializer.addNodeFilter APIs. Acknowledgements Tiny Technologies would like to thank Toni Huttunen of Fraktal Oy for discovering this vulnerability. References - TinyMCE 6.8.1 - TinyMCE 7.0.0

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5359-pvf2-pw78

  2. Revision 1 · created ·

    Published from osv record GHSA-5359-pvf2-pw78

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-29881

Advisory: TinyMCE Cross-Site Scripting (XSS) vulnerability in handling external SVG files through Object or Embed elements
IDs: CVE-2024-29881, GHSA-5359-pvf2-pw78
Record: https://patchnext.com/advisories/cve-2024-29881 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tinymce 7.0.0; tinymce/tinymce 7.0.0; tinymce 7.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet tinymce: affected < 7.0.0; fixed in 7.0.0
- Packagist tinymce/tinymce: affected < 7.0.0; fixed in 7.0.0
- npm tinymce: affected < 7.0.0; fixed in 7.0.0

## Suggested inspection (read-only)
- NuGet tinymce: check the installed version with your package manager.
- Packagist tinymce/tinymce: check the installed version with your package manager.
- `npm ls tinymce --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tinymce, tinymce/tinymce.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5359-pvf2-pw78 (OSV record GHSA-5359-pvf2-pw78 lists affected ranges: Packagist tinymce/tinymce >=0 =0 =0 <7.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-5359-pvf2-pw78 (GitHub-reviewed advisory GHSA-5359-pvf2-pw78 lists affected ranges: Packagist tinymce/tinymce >=0 =0 =0 <7.0.0)

Commands are suggestions: review each one before running it.

Loading voting…