Apache Pulsar: Improper Authorization For Namespace and Topic Management Endpoints
CVE-2024-29834GHSA-7mg2-6c6v-342r
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.pulsar:pulsar-broker
- Affected
- >= 2.7.1, <= 2.10.6>= 2.11.0, <= 2.11.4>= 3.0.0, < 3.0.4>= 3.1.0, <= 3.1.3>= 3.2.0, < 3.2.2
- Fixed in
- 3.0.4, 3.2.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7mg2-6c6v-342r lists affected ranges: Maven org.apache.pulsar:pulsar-broker >=2.7.1 =2.11.0 =3.0.0 =3.1.0 =3.2.0 <3.2.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- EPSS
- CVE-2024-29834: 1.36% estimated exploitation activity in the next 30 days; percentile 71.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This vulnerability allows authenticated users with produce or consume permissions to perform unauthorized operations on partitioned topics, such as unloading topics and triggering compaction. These management operations should be restricted to users with the tenant admin role or superuser role. An authenticated user with produce permission can create subscriptions and update subscription properties on partitioned topics, even though this should be limited to users with consume permissions. This impact analysis assumes that Pulsar has been configured with the default authorization provider. For custom authorization providers, the impact could be slightly different. Additionally, the vulnerability allows an authenticated user to read, create, modify, and delete namespace properties in any namespace in any tenant. In Pulsar, namespace properties are reserved for user provided metadata about the namespace. This issue affects Apache Pulsar versions from 2.7.1 to 2.10.6, from 2.11.0 to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7mg2-6c6v-342r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-29834 Advisory: Apache Pulsar: Improper Authorization For Namespace and Topic Management Endpoints IDs: CVE-2024-29834, GHSA-7mg2-6c6v-342r Record: https://patchnext.com/advisories/cve-2024-29834 (revision 1, source checked 26 Oct 2026, 16:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.apache.pulsar:pulsar-broker 3.2.2, 3.0.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.pulsar:pulsar-broker: affected >= 2.7.1, <= 2.10.6; >= 2.11.0, <= 2.11.4; >= 3.0.0, < 3.0.4; >= 3.1.0, <= 3.1.3; >= 3.2.0, < 3.2.2; fixed in 3.0.4, 3.2.2 ## Suggested inspection (read-only) - Maven org.apache.pulsar:pulsar-broker: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.pulsar:pulsar-broker. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7mg2-6c6v-342r (GitHub-reviewed advisory GHSA-7mg2-6c6v-342r lists affected ranges: Maven org.apache.pulsar:pulsar-broker >=2.7.1 =2.11.0 =3.0.0 =3.1.0 =3.2.0 <3.2.2) Commands are suggestions: review each one before running it.
Loading voting…