Skip to content

← Actionable
Medium, CVSS 5.3amended

Apache Airflow Improper Preservation of Permissions vulnerability

CVE-2024-29735GHSA-cff3-5qrp-hqx7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 2.8.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2024-29735: 1.46% estimated exploitation activity in the next 30 days; percentile 73.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Improper Preservation of Permissions vulnerability in Apache Airflow. This issue affects Apache Airflow from 2.8.2 through 2.8.3. Airflow's local file task handler in Airflow incorrectly set permissions for all parent folders of log folder, in default configuration adding write access to Unix group of the folders. In the case Airflow is run with the root user (not recommended) it added group write permission to all folders up to the root of the filesystem. If your log files are stored in the home directory, these permission changes might impact your ability to run SSH operations after your home directory becomes group-writeable. This issue does not affect users who use or extend Airflow using Official Airflow Docker reference images ( https://hub.docker.com/r/apache/airflow/ ) - those images require to have group write permission set anyway. You are affected only if you install Airflow using local installation / virtualenv or other Docker images, but the issue has no impact if docker…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cff3-5qrp-hqx7

  2. Revision 1 · created ·

    Published from osv record GHSA-cff3-5qrp-hqx7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-29735

Advisory: Apache Airflow Improper Preservation of Permissions vulnerability
IDs: CVE-2024-29735, GHSA-cff3-5qrp-hqx7
Record: https://patchnext.com/advisories/cve-2024-29735 (revision 2, source checked 26 Oct 2026, 13:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apache-airflow 2.8.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI apache-airflow: affected >= 2.8.2, < 2.8.4; fixed in 2.8.4

## Suggested inspection (read-only)
- `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apache-airflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cff3-5qrp-hqx7 (OSV record GHSA-cff3-5qrp-hqx7 lists affected ranges: PyPI apache-airflow >=2.8.2 <2.8.4 (fixed))
- Verified: https://github.com/advisories/GHSA-cff3-5qrp-hqx7 (GitHub-reviewed advisory GHSA-cff3-5qrp-hqx7 lists affected ranges: PyPI apache-airflow >=2.8.2 <2.8.4)

Commands are suggestions: review each one before running it.

Loading voting…