Sylius has potential Cross Site Scripting vulnerability via the "Province" field in the Checkout and Address Book
CVE-2024-29376GHSA-7prj-9ccr-hr3q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sylius/sylius 1.13.1, 1.12.16, 1.11.17, 1.10.16, 1.9.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist sylius/sylius
- Affected
- >= 1.12.0-alpha.1, < 1.12.16>= 1.13.0-alpha.1, < 1.13.1< 1.9.12>= 1.10.0-alpha.1, < 1.10.16>= 1.11.0-alpha.1, < 1.11.17
- Fixed in
- 1.10.16, 1.11.17, 1.12.16, 1.9.12, 1.13.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7prj-9ccr-hr3q lists affected ranges: Packagist sylius/sylius >=1.12.0-alpha.1 =1.13.0-alpha.1 =0 =1.10.0-alpha.1 =1.11.0-alpha.1 <1.11.17
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2024-29376: 0.42% estimated exploitation activity in the next 30 days; percentile 36.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact There is a possibility to save XSS code in province field in the Checkout and Address Book and then execute it on these pages. The problem occurs when you open the address step page in the checkout or edit the address in the address book. This only affects the base UI Shop provided by Sylius. Patches The issue is fixed in versions: 1.9.12, 1.10.16, 1.11.17, 1.12.16, 1.13.1 and above. Workarounds 1. Create new file assets/shop/sylius-province-field.js: 2. Add new import in assets/shop/entry.js: 3. If you're using Gulp, update your gulpfile.babel.js: 4. Rebuild your assets: Acknowledgements This security issue has been reported by @r2tunes, thank you! References - The original advisory: https://github.com/advisories/GHSA-mw82-6m2g-qh6c For more information If you have any questions or comments about this advisory: Open an issue in Sylius issues Email us at security@sylius.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7prj-9ccr-hr3q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-29376 Advisory: Sylius has potential Cross Site Scripting vulnerability via the "Province" field in the Checkout and Address Book IDs: CVE-2024-29376, GHSA-7prj-9ccr-hr3q Record: https://patchnext.com/advisories/cve-2024-29376 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sylius/sylius 1.13.1, 1.12.16, 1.11.17, 1.10.16, 1.9.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist sylius/sylius: affected >= 1.12.0-alpha.1, < 1.12.16; >= 1.13.0-alpha.1, < 1.13.1; < 1.9.12; >= 1.10.0-alpha.1, < 1.10.16; >= 1.11.0-alpha.1, < 1.11.17; fixed in 1.10.16, 1.11.17, 1.12.16, 1.9.12, 1.13.1 ## Suggested inspection (read-only) - Packagist sylius/sylius: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sylius/sylius. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7prj-9ccr-hr3q (GitHub-reviewed advisory GHSA-7prj-9ccr-hr3q lists affected ranges: Packagist sylius/sylius >=1.12.0-alpha.1 =1.13.0-alpha.1 =0 =1.10.0-alpha.1 =1.11.0-alpha.1 <1.11.17) Commands are suggestions: review each one before running it.
Loading voting…