Skip to content

← Actionable
Medium, CVSS 4.3amended

TinyMCE Cross-Site Scripting (XSS) vulnerability in handling iframes

CVE-2024-29203GHSA-438c-3975-5x3f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tinymce 6.8.1; tinymce/tinymce 6.8.1; tinymce 6.8.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
EPSS
  • CVE-2024-29203: 0.71% estimated exploitation activity in the next 30 days; percentile 53.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content insertion code. This allowed iframe elements containing malicious code to execute when inserted into the editor. These iframe elements are restricted in their permissions by same-origin browser protections, but could still trigger operations such as downloading of malicious assets. Fix TinyMCE 6.8.1 introduced a new sandboxiframes boolean option which adds the sandbox="" attribute to every iframe element by default when enabled. This will prevent cross-origin, and in special cases same-origin, XSS by embedded resources in iframe elements. From TinyMCE 7.0.0 onwards the default value of this option is true. In TinyMCE 7.0.0 a new sandboxiframesexclusions option was also added, allowing a list of domains to be specified that should be excluded from having the sandbox="" attribute applied when the sandboxiframes option is enabled. By default, this option is set to an array of domains that are provided…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-438c-3975-5x3f

  2. Revision 1 · created ·

    Published from osv record GHSA-438c-3975-5x3f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-29203

Advisory: TinyMCE Cross-Site Scripting (XSS) vulnerability in handling iframes
IDs: CVE-2024-29203, GHSA-438c-3975-5x3f
Record: https://patchnext.com/advisories/cve-2024-29203 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tinymce 6.8.1; tinymce/tinymce 6.8.1; tinymce 6.8.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet tinymce: affected < 6.8.1; fixed in 6.8.1
- Packagist tinymce/tinymce: affected < 6.8.1; fixed in 6.8.1
- npm tinymce: affected < 6.8.1; fixed in 6.8.1

## Suggested inspection (read-only)
- NuGet tinymce: check the installed version with your package manager.
- Packagist tinymce/tinymce: check the installed version with your package manager.
- `npm ls tinymce --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tinymce, tinymce/tinymce.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-438c-3975-5x3f (OSV record GHSA-438c-3975-5x3f lists affected ranges: npm tinymce >=0 =0 =0 <6.8.1 (fixed))
- Verified: https://github.com/advisories/GHSA-438c-3975-5x3f (GitHub-reviewed advisory GHSA-438c-3975-5x3f lists affected ranges: npm tinymce >=0 =0 =0 <6.8.1)

Commands are suggestions: review each one before running it.

Loading voting…