Skip to content

← Actionable
High, CVSS 7.5

GeoServer Vulnerable to Unauthenticated SSRF via TestWfsPost

CVE-2024-29198GHSA-5gw5-jccf-6hxw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.geoserver:gs-wfs 2.25.2, 2.24.4; org.geoserver.web:gs-app 2.25.2, 2.24.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2024-29198: 2.30% estimated exploitation activity in the next 30 days; percentile 83.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary It possible to achieve Service Side Request Forgery (SSRF) via the Demo request endpoint if Proxy Base URL has not been set. Details A unauthenticated user can supply a request that will be issued by the server. This can be used to enumerate internal networks and also in the case of cloud instances can be used to obtain sensitive data. Mitigation 1. When using GeoServer with a proxy, manage the proxy base value as a system administrator, use the application property PROXYBASEURL to provide a non-empty value that cannot be overridden by the user interface or incoming request. 2. When using GeoServer directly without a proxy, block all access to TestWfsPost by editing the web.xml file. Adding this block right before the end: Resolution Upgrading to GeoServer 2.24.4, or 2.25.2, removes the TestWfsPost servlet resolving this issue. The demo request page functionality is now implemented directly in the browser. Reference - https://osgeo-org.atlassian.net/browse/GEOS-11794 -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5gw5-jccf-6hxw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-29198

Advisory: GeoServer Vulnerable to Unauthenticated SSRF via TestWfsPost
IDs: CVE-2024-29198, GHSA-5gw5-jccf-6hxw
Record: https://patchnext.com/advisories/cve-2024-29198 (revision 1, source checked 26 Oct 2026, 16:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.geoserver:gs-wfs 2.25.2, 2.24.4; org.geoserver.web:gs-app 2.25.2, 2.24.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.geoserver:gs-wfs: affected >= 2.0.0, < 2.24.4; >= 2.25.0, < 2.25.2; fixed in 2.24.4, 2.25.2
- Maven org.geoserver.web:gs-app: affected >= 2.0.0, < 2.24.4; >= 2.25.0, < 2.25.2; fixed in 2.24.4, 2.25.2

## Suggested inspection (read-only)
- Maven org.geoserver:gs-wfs: check the installed version with your package manager.
- Maven org.geoserver.web:gs-app: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.geoserver:gs-wfs, org.geoserver.web:gs-app.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5gw5-jccf-6hxw (GitHub-reviewed advisory GHSA-5gw5-jccf-6hxw lists affected ranges: Maven org.geoserver:gs-wfs >=2.0.0 =2.25.0 =2.0.0 =2.25.0 <2.25.2)

Commands are suggestions: review each one before running it.

Loading voting…