OneUptime Vulnerable to a Privilege Escalation via Local Storage Key Manipulation
CVE-2024-29194GHSA-246p-xmg8-wmcq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@oneuptime/model 7.0.1815; @oneuptime/common-server 7.0.1815), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @oneuptime/model
- Affected
- < 7.0.1815
- Fixed in
- 7.0.1815
- Affected
- < 7.0.1815
- Fixed in
- 7.0.1815
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-246p-xmg8-wmcq lists affected ranges: npm @oneuptime/model >=0 =0 <7.0.1815 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-246p-xmg8-wmcq lists affected ranges: npm @oneuptime/model >=0 =0 <7.0.1815
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
- EPSS
- CVE-2024-29194: 0.70% estimated exploitation activity in the next 30 days; percentile 53.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A security vulnerability exists in oneuptime's local storage handling, where a regular user can escalate privileges by modifying the ismasteradmin key to true. This allows unauthorized access to administrative functionalities. Details The vulnerability lies in the improper validation of client-side stored data within the web application. Specifically, the ismasteradmin key, stored in the local storage of the browser, can be manipulated by an attacker. By changing this key from false to true, the application grants administrative privileges to the user, without proper server-side validation. POC (I am using Firefox Developer to demonstrate this vulnerability) Log in as a normal user. Open developer tools (hit F12), click Storage, then Local Storage. Modify the ismasteradmin key from false to true. Impact This vulnerability represents a high security risk as it allows any authenticated user to gain administrative privileges through client-side manipulation. Most of the admin…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-246p-xmg8-wmcq
- Revision 1 · created ·
Published from osv record GHSA-246p-xmg8-wmcq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-29194 Advisory: OneUptime Vulnerable to a Privilege Escalation via Local Storage Key Manipulation IDs: CVE-2024-29194, GHSA-246p-xmg8-wmcq Record: https://patchnext.com/advisories/cve-2024-29194 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @oneuptime/model 7.0.1815; @oneuptime/common-server 7.0.1815. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @oneuptime/model: affected < 7.0.1815; fixed in 7.0.1815 - npm @oneuptime/common-server: affected < 7.0.1815; fixed in 7.0.1815 ## Suggested inspection (read-only) - `npm ls @oneuptime/model --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @oneuptime/common-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @oneuptime/model, @oneuptime/common-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-246p-xmg8-wmcq (OSV record GHSA-246p-xmg8-wmcq lists affected ranges: npm @oneuptime/model >=0 =0 <7.0.1815 (fixed)) - Verified: https://github.com/advisories/GHSA-246p-xmg8-wmcq (GitHub-reviewed advisory GHSA-246p-xmg8-wmcq lists affected ranges: npm @oneuptime/model >=0 =0 <7.0.1815) Commands are suggestions: review each one before running it.
Loading voting…