Skip to content

← Actionable
Medium, CVSS 5.3

Slow String Operations via MultiPart Requests in Event-Driven Functions

CVE-2024-29186GHSA-j4hq-f63x-f39r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bref/bref 2.1.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist bref/bref

    Affected
    < 2.1.17
    Fixed in
    2.1.17

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2024-29186: 0.67% estimated exploitation activity in the next 30 days; percentile 51.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impacted Resources bref/src/Event/Http/Psr7Bridge.php:94-125 multipart-parser/src/StreamedPart.php:383-418 Description When Bref is used with the Event-Driven Function runtime and the handler is a RequestHandlerInterface, then the Lambda event is converted to a PSR7 object. During the conversion process, if the request is a MultiPart, each part is parsed. In the parsing process, the Content-Type header of each part is read using the Riverline/multipart-parser library. The library, in the StreamedPart::parseHeaderContent function, performs slow multi-byte string operations on the header value. Precisely, the mbconvertencoding function is used with the first ($string) and third ($fromencoding) parameters read from the header value. Impact An attacker could send specifically crafted requests which would force the server into performing long operations with a consequent long billed duration. The attack has the following requirements and limitations: - The Lambda should use the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j4hq-f63x-f39r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-29186

Advisory: Slow String Operations via MultiPart Requests in Event-Driven Functions
IDs: CVE-2024-29186, GHSA-j4hq-f63x-f39r
Record: https://patchnext.com/advisories/cve-2024-29186 (revision 1, source checked 26 Oct 2026, 14:18 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bref/bref 2.1.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist bref/bref: affected < 2.1.17; fixed in 2.1.17

## Suggested inspection (read-only)
- Packagist bref/bref: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bref/bref.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j4hq-f63x-f39r (GitHub-reviewed advisory GHSA-j4hq-f63x-f39r lists affected ranges: Packagist bref/bref >=0 <2.1.17)

Commands are suggestions: review each one before running it.

Loading voting…