Skip to content

← Actionable
Low, CVSS 2.3amended

@strapi/plugin-content-manager leaks data via relations via the Admin Panel

CVE-2024-29181GHSA-6j89-frxc-q26m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@strapi/plugin-content-manager 4.19.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.3 · CVSS:3.1/AV:A/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N
EPSS
  • CVE-2024-29181: 0.39% estimated exploitation activity in the next 30 days; percentile 32.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary 1. If a super admin creates a collection where an item in the collection has an association to another collection, a user with the Author Role can see the list of associated items they did not create. They should only see their own items that they created, not all items ever created. Details At the top level every collection shows blank items for an Author if they did not create the item. This is ideal and works great. However if you associate one private collection to another private collection and an Author creates a new item. The pull down should not show the admins list of previously created items. It should be blank unitl they add their own items. PoC 1. Sign in as Admin. Navigate to content creation. 2. Select a collection and verify you have items you created there. And that they have associations to other protected collections. 3. Verify role permissions for your collections are set to CRUD if user created. 4. Log out and sign in as a unrelated Author. 5. Navigate to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6j89-frxc-q26m

  2. Revision 1 · created ·

    Published from osv record GHSA-6j89-frxc-q26m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-29181

Advisory: @strapi/plugin-content-manager leaks data via relations via the Admin Panel
IDs: CVE-2024-29181, GHSA-6j89-frxc-q26m
Record: https://patchnext.com/advisories/cve-2024-29181 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @strapi/plugin-content-manager 4.19.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @strapi/plugin-content-manager: affected < 4.19.1; fixed in 4.19.1

## Suggested inspection (read-only)
- `npm ls @strapi/plugin-content-manager --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @strapi/plugin-content-manager.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6j89-frxc-q26m (OSV record GHSA-6j89-frxc-q26m lists affected ranges: npm @strapi/plugin-content-manager >=0 <4.19.1 (fixed))
- Verified: https://github.com/advisories/GHSA-6j89-frxc-q26m (GitHub-reviewed advisory GHSA-6j89-frxc-q26m lists affected ranges: npm @strapi/plugin-content-manager >=0 <4.19.1)

Commands are suggestions: review each one before running it.

Loading voting…